Pages: [1]   Go Down
Author Topic: Slight sound cooming from pin on noTone  (Read 541 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello all,
Ive got a project with a simple buzzer that will trigger with the tone().
When the speaker is off, however, there is still a slight noise emanating from it, which will drive me crazy.
Whether this is from the arduino or my powersupply or whatever, I need to get rid of it. Is there a way I can simply filter that out, something like a pull-down resistor? Ive really got no clue about these things related to audio. Any insight is appreciated.
Thanks!!
Logged

Offline Offline
Edison Member
*
Karma: 58
Posts: 2078
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I would like to try it, but I need to know a lot more.
Can you tell which Arduino board and can you upload a test sketch ?
Do you use a switchting power supply ? Which one ? can you upload a photo of it ?
Are there other things connected ?
What happens if you use the USB to power it ?

I hope you don't use a very cheap switching power supply from Ebay. The led drivers are the worst.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I know now that it is coming through the power line.... I am using a wall powersupply, not ebay cheap, but not rolls royce either.I swapped it out for a lm7805 and 9v battery, with 10uf on each side. It is still there. Perhaps its because Im using such a sensitive piezo buzzer
Logged

Offline Offline
Edison Member
*
Karma: 58
Posts: 2078
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I did this:
Usb powered, piezo at pin 10.
After noTone() the piezo is super silent, and the voltage on pin 10 is almost zero (4mV).

Check carefully for shortcuts. Could you try another pin ?

Can you do a test sketch ? For example use pinMode(pinPiezo, OUTPUT) and digitWrite(pinPiezo, LOW).
Do you still hear something ?
If not, try pinMode( pinPiezo, INPUT), without the digitalWrite.
How long does it take after power on before you hear something ?
If using INPUT returns the sound, can you change your sketch and use pinMode(pinPiezo, OUTPUT) and digitalWrite(pinPiezo, LOW) after every noTone() ?

Can you upload a photo of it, with the wires ?

Perhaps your neighbour has a MegaWatt transmitter in his basement ?
« Last Edit: March 23, 2013, 03:38:03 am by Erdin » Logged

Pages: [1]   Go Up
Jump to: