Go Down

Topic: IDE fails to find system libraries? (Read 414 times) previous topic - next topic

Msquare

Compilation (Verify) fails saying it can not find LiquidCrystal.h (also tried Stepper.h - same problem).

I have downloaded the Merlin package to drive 3D printers. It compiles fine on my WIN XP, my laptop with Win7(Enterprise) but fails on another Win7(Pro) machine. OK, the Merlin is a large package, so I tried with a sketch from Examples-LiquidCrystal. Same problem/symptoms.

Fresh download of the Arduino software did not help.  If I mess with the keywords.txt file in the LiquidCrystal system library (and restart) then it correctly fails to color keywords I have removed - so it can find&read the library-directory.

I've done this lots of times on other machines so I am looking for a clue what to check for. Out of ideas....

(As a workaround - what would be a simple way to copy the .hex file from the working machine and upload on the nonworking one?)

Coding Badly


This compiles without error...

Code: [Select]
#include <whatever.h>  // <<<<<<<<<< No whatever.h on this computer!

void setup( void ) { }
void loop( void ) { }



Post the verbose output from a compilation attempt.

Msquare

Thanks. I do not have access to that machine unless I travel accross town which is a hassle so it will be some time before I get the verbose output. But IIRC it simply says that in a given submodule it fails to find the file "LiquidCrystal.h". Then come all the following errors due to the missing header/prototypes.

I took along my laptop, compiled and uploaded to the Arduino, and then moved the USB to the mystery machine to drive it from the printerapplication (Pronterface). Its not a good solution. (I forgot to snapshot the error messages :( but it still fails compile)

I'll return as soon as I have more info. Anyone have some suggestion what to try or workaround?

Msquare

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy