Go Down

Topic: GPS Bee and Bees Shield from Seeedstudio (Read 1 time) previous topic - next topic


I'm new to the hardware side of things so pardon any faux pas. I'm trying to read GPS NMEA strings on a software serial and write them out to the hardware serial so I can see them on the serial monitor, but I can't seem to get any NMEA strings.

I have an Arduino Uno R3, Bees shield, and GPS Bee.

  • http://www.seeedstudio.com/depot/bees-shield-p-672.html?cPath=132_134

  • http://www.seeedstudio.com/depot/gps-bee-kit-with-mini-embedded-antenna-p-560.html?cPath=144_145

Here's the code I've uploaded to my board (I've tried baud rate of both 9600 and 4800 for the software serial).
Code: [Select]
#include "SoftwareSerial.h"

const unsigned int GPS_RX = 11;
const unsigned int GPS_TX = 12;

SoftwareSerial ss(GPS_RX, GPS_TX);

void setup() {
  Serial.begin(9600); //baud rate for pc hw serial
  ss.begin(9600); //baud rate may be wrong? 4800

void loop() {
  Serial.print("\nloop | ");
  while(ss.available()) {
    Serial.write("ss is available |");
    int data = ss.read();

This is what I normally get back:
Code: [Select]
loop |
loop |
loop |
loop |

Sometimes I see that the software serial is available and Serial.write() returns a space while Serial.print() return a zero (though it seems to only happen if I'm holding everything together in my hands a certain way). I'm inside an apartment, so maybe it's not connecting, but shouldn't I regularly receive something from the GPS?

Code: [Select]

loop | ss is available | |

Similar issue with no resolution:

Any suggestion as to what I'm doing wrong would be much appreciated. If I can provide any more information, please tell me. Thank you.


The XBee shield has a bunch of jumpers on it. Where are yours?


The XBee shield has a bunch of jumpers on it. Where are yours?

My Bees shield came with 2 jumpers. When running this code, Bee1_TX jumper is on pin 12 and Bee1_RX is on pin 11. I originally tried pins 9 and 10 if that's relevant. Is there a wrong way to put jumpers on? This only requires the jumpers, not any wires, correct? Thanks.


Also, I have the switch pointed at Atmega.

I tried swapping out the GPS bee as well as the Bees shield (since I have 2 of each) to try to rule out receiving a malfunctioning piece of hardware. I get the same results.


For cross reference, I've posted the same post on Seeed Studio's forum here:

  • http://www.seeedstudio.com/forum/viewtopic.php?f=18&t=4336

Again, any help/suggestions with this would be greatly appreciated. I've tried everything I can think of many times over with no luck. Thanks.

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131