Go Down

Topic: Driver Errors & Code 37 (Read 113 times) previous topic - next topic

Aetos81

Nov 19, 2014, 06:31 am Last Edit: Nov 19, 2014, 06:35 am by Aetos81
Fellas,

I am new to the whole Arduino platform and wanted to give it a shot.  Here's my setup:


Arduino Mega 2560
Windows 7


I wasn't able to find anything in the troubleshooting guide that had any solutions for this issue, but here's how I got here.  I followed the instructions for the Arduino drivers installation for 1.0.6 and had no luck.  Windows was able to identify the device and assign it a COM port in the Device Manager, but it shows the following message when you click on the Arduino Mega 2560:



"Windows cannot initialize the device driver for this hardware. (Code 37)"



In the Arduino software, it won't even allow me to select anything from Tools / Serial Port option.  The entire Serial Port option is grayed out.  Also, the Mega never gets a green LED.  The red LED for power comes on when it's plugged into the USB port, and the second LED is labled "L" and blinks red in an off and on pattern of about 1 second per cycle.


I did find a thread on there that had an optimized installed for 1.0.5, so I removed everything and gave it a shot.  I had the same results with the COM port, the error message, and the Arduino flashing the red LED, regardless of which software / drivers were loaded.


Any suggestions?


Thanks,


Pete

Coding Badly


Navigate to the Driver tab and click Driver Details.  Post an image of that dialog box.


Aetos81

Here's what I got for the driver details.

-Pete

Aetos81

#3
Nov 21, 2014, 02:56 pm Last Edit: Nov 21, 2014, 02:57 pm by Aetos81
Any ideas?  Anybody?  Tried running through whatever help I could find online for a Code 37 resolution for other devices / other drivers that couldn't, but nothing has seemed to do the trick yet. 

I did install 1.0.6 on a friend's laptop with Windows 7, ran the install the same way that I did on my computer, and The Mega was able to communicate with his computer, so I know that it's not a broken Arduino. 

Just can't figure out why I can't get it to talk with my computer...

Pete

Coding Badly


My guess is that the lower driver (the USB chipset driver) is causing the problem.  There really is not anything else that would explain the symptom.

There are reports that the following, run from a command shell that was run-as-administrator, has solved code 37 errors...
sfc /scannow


ChilliTronix

Post a link to the actual board you have so we can check the USB chip.

Go Up