Go Down

Topic: Pull down resistor on servo signal line? (Read 1 time) previous topic - next topic

tatticus

I have a project I'm working on that uses a lower end HiTech servo.

It's being powered by 5v from the arduino board (BBB, Modern Devices).

Once and awhile I can faintly hear the servo kind of "hiccup" (just a slight bzzzzzt lasting a fraction of a second with no perceivable movement in the servo horn). I have a feeling the signal line is picking up some interference? Would a pull-down resistor on the signal line solve this (10k?)? My gut tells me though the servo's electronic package already pulls the signal line to ground though so I'm not sure.

Any ideas? I'd like to eliminate this annoyance issue.



Grumpy_Mike

I doubt that a pull down would make any difference, I think you have another problem but there is not enough information supplied to hazard a guess.
If you want to post the code and a schematic theat might be something some one can spot.

JimboZA

I'd rather suspect the problem is insufficient power on the supply, not a problem on the control line.

Try hooking the servo 5V and ground to its own supply, not from the Arduino, making sure to connect the servo ground to the Arduino ground.
Arduino ethernet server here.... http://jimboza.gotdns.com:8085/ (not always alive tho)
Don't read too much into my being a Faraday Member: that just means I post a lot, not that I know much.

No PMs for help please

oric_dan

From my experience, I would also think it's a power supply problem, and not a signal
problem. The power leads should be short and heavy. Also, I always put bypass [100 nF]
and electrolytic caps [100-220 uF] across the servo power buss to help filter noise.

All in all, you should probably try different things to get more info. Eg, start with tacking
a pulldown on the signal wire, and see if that helps, on and on.

zoomkat

Typical servo external power supply setup. I've seen servos occasionally twitch when being controlled by an arduino, but don't remember the cause or fix.

Google forum search: Use Google Advanced Search and use Http://forum.arduino.cc/index in the "site or domain:" box.

scswift

Are you doing anything else in the code besides updating the servos?  Specifically anything which uses interrupts or disables them?  I've found that when the timing of the pulses that goes to the servos isn't perfect the servo will do that since it thinks it's slightly off from there it should be.

Go Up