Go Down

Topic: Dont load any sketch (Read 385 times) previous topic - next topic

mamk90

Yesterday I was playing with my arduino mega 2560, I was checking the serial communication, today when i connect the arduino to the pc, the pin 13 led is blinking and when I try to load any sketch I receive this error


avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer

I try the loop-back test and everything was alright...
And i reinstall the firmware but it still blinking

James C4S


And i reinstall the firmware but it still blinking

What firmware?
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

mamk90

Arduino-usbserial-mega.hex with atmel flip 3.4.1

James C4S

If the board appears as a serial port on your PC, then there probably wasn't a reason to reflash the usb to serial chip.

You might need to reflash the actual ATmega2560's bootloader.

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com


Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy