Go Down

Topic: IDE arduino compatible cartes ChipKit MAX32 (Read 611 times) previous topic - next topic

Mike74

Bonjour,

Je souhaiterai savoir si il existait une solution pour rendre compatible l'IDE arduino 1.5.2 avec les carte ChipKIT Max32, après analyse j'ai essayé simplement de copier les répertoires spécifiques au PIC et au driver se trouvant sur l'IDE chipKit et les copier dans le repertoire de l'IDE Arduino mais cela ne fonctionne pas.

Merci.

skywodd

Bonjour,

Encore quelqu'un qui n'as pas lui les doc ... :smiley-roll:

1) l'IDE arduino 1.5.2 est une version BETA réservé pour le moment à l'arduino DUE.
(elle est utilisable pour les cartes "classiques" mais pas conseillé pour le moment, c'est une beta !)

2) les cartes ChipKIT sont basés sur des microcontrôleurs PIC32 de Microchip :
--> ce n'est pas le même type / architecture / fabricant de cpu que les cartes arduino officielles
--> ce n'est pas le même compilateur
--> ce n'est pas le même code qui va derrière (même si les fonctions "haut niveau" arduino sont les mêmes)
Il n'y a donc rien à rendre compatible, ce sont (arduino / chipkit) deux projets totalement séparé ayant juste une API commune.

3) l'IDE chipKit est une version spécialement modifié de l'ide arduino "de base" conçu justement pour fonctionner avec le compilateur pour PIC32.
Pour programmer sur chipkit il faut l'ide chipkit, c'est pas plus simple que ça.

À noter que :
- les librairies arduino pour cartes arduino "classiques" ne sont pas compatible chipkit à moins qu'elles n'utilisent que les fonctions "haut niveau" arduino
- l'ide 1.5.2 est à conçu (ou du moins prévu) pour gérer plusieurs types de compilateurs / architectures mais ce n'est pas encore à ce stade
Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

Mike74

Merci pour ces informations et oui c'est dommage que certaines librairies ne soient pas compatibles (lors de la compilation) avec l'IDE chipKit.

Merci.

skywodd


Merci pour ces informations et oui c'est dommage que certaines librairies ne soient pas compatibles (lors de la compilation) avec l'IDE chipKit.

Il y a aussi des librairies qui compilent mais qui ne marcherons pas à l'exécution ;)
Déjà rien que les librairies de base c'est pas jolie : http://www.chipkit.org/wiki/index.php?title=Library_Status
Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

Go Up