Go Down

Topic: "Unable" to type any numbers into arduino IDE (Read 2011 times) previous topic - next topic


I was interacting with a few volunteers the other day on my arduino projects. One of them couldn't type anything on the number row into Arduino IDE. I tried it, nothing above the "qwert" row gets into the IDE. I then said to myself that we don't have admin's privillege on those lab computers, so maybe something was screwed. I tried to type in to Word and copied everything into arduino IDE but everything looked weired and arduino can't compile.

Then I finally realized that the student was using a Chinese input. Darn. I didn't know that the input generates different characters for numbers, commas and parentheses than ascii and arduino IDE can't understand them so it won't even take them. I was fairly relieved when I found out what was causing it.

Thinking about this, I thought why can't arduino IDE take maybe UTF characters, nice for comments in authors' native languages. But that may create yet another problem, where someone is typing with his native language input and the letters and numbers are encoded differently than say ASCII and the compiler won't compile.  ;D

Coding Badly

Thinking about this, I thought why can't arduino IDE take maybe UTF characters, nice for comments in authors' native languages.

Just because it doesn't work with the Chinese keyboard layout doesn't mean that it doesn't work in general.

A few folks on this forum have asked how they could work with non-ASCII characters.  Typically, they have wanted to display the characters on an LCD display or on the Serial Monitor.  In all the cases that I can remember, the user was able to enter the Unicode characters into the Arduino editor and the characters were successfully displayed, saved, and loaded.  In one case, I was able to copy the source code from Internet Explorer and paste it unaltered into the Arduino editor.  As far as I can tell, the IDE treats source files as UTF-8.

I believe, the compiler sees source files as an array of bytes so Unicode identifiers probably won't work.  But, Unicode characters in text strings and comments seem to be fine.


Jan 03, 2011, 07:39 am Last Edit: Jan 03, 2011, 07:42 am by Osgeld Reason: 1
I actually have that issue on the Korean layouts at work, though we use US windows with the language packs installed so we just hit a button and its back to normal

I have never tried it with a 100% right up Korean install

I have a feeling it works best with latin based input


Thanks for the feedbacks Coding Badly and Osgeld. It might be just the input method that is creating some Chinese encoding even for numbers.

Go Up