Pages: [1]   Go Down
Author Topic: HerkuleX DRS-0201 Communication Problem  (Read 913 times)
0 Members and 1 Guest are viewing this topic.
Ireland
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi guys im new to Arduino. Just go it and i was following the steps that are given from dongu

http://www.sgbotic.com/products/datasheets/robotics/HerkuleX_Arduino_library_Quickstart_Eng.pdf

to communicate between my Herkulex DRS-0201 and Arduino Uno board i've got. At the start i set the baudrate to 115200 on Arduino and on Herkulex manager is 115200 baudrate and show me that is on COM3 same as on Arduino. But the voltage im using is 9V not as recommended 7.4V as i dont have a charger with that type of voltage. I connected everything the same way as is on the picture in pdf file. While the program is downloading to Aruino uno board the servo motor starts to blinking red(means that somethink is wrong).



So i disconnect the power and usb from the board and i connect back power then usb and red flashing will come back on servo.
On HerkuleX Manager show me that there is communication on COM3 but it wont connect when i click "Connect"

Any ideas, guys that could help me solve the problem. Cheers.
Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 548
Posts: 46026
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Are you trying to talk to the HerkuleX using code on the Arduino or code on the PC?

It sounds to me like the answer is yes, which is not the correct answer.
Logged

Ireland
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Sorry but i don't understand you, so how should i code this? I just followed the steps that are in pdf file.
Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 548
Posts: 46026
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
On HerkuleX Manager show me that there is communication on COM3 but it wont connect when i click "Connect"
This suggests that the device is connected to the PC. If that is the case, how is the Arduino supposed to talk to it? If it isn't connected to the PC, is it any wonder why the PC can't talk to it?
Logged

Ireland
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi PaulS, i've got to the task where i control the servo with arduino software.The problem was, where i upload the code on arduino the baudrate was set to:
Code:
HerkuleX.begin(57600, RX, TX);
where the default baudrate for HerkuleX servos is 115200 so i change code to:
Code:
HerkuleX.begin(115200, RX, TX);
Then in Arduino software, in monitor mode i was able to move the position of the servo as is shown in pdf file, Point4 (2)Test .

But im still having problem with HerkuleX Manager software when i change the setting to the right COM the same as arduino board is connected to and change the baudrate to 115200 and i click "Connect" still HerklueX Manager can't find the HerkuleX Servo model. So i could change the baudrate communication to 57600.

Any clues. Thanks Lukas
Logged

Pages: [1]   Go Up
Jump to: