Pages: [1]   Go Down
Author Topic: sync problem  (Read 294 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 16
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,
i suddenly have a problem in my arduino uno
Whereas everything worked fine suddenly when i tried to upload the prog i got this message:

avrdude: stk500_paged_write(): (a) protocol error, expect=0x14, resp=0x64
avrdude: stk500_cmd(): programmer is out of sync

What is the problem ? Can someone help me?
Thanks a lot
sorry my english is not very good
Logged

Rome, Italy
Offline Offline
Sr. Member
****
Karma: 20
Posts: 442
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Can you provide more information about which version of the IDE you are using and what you are trying to do? The message may depend on your choosing a different board (Tools - Board menu) or trying to do an "Upload using a programmer" instead of a normal upload. Also knowing something about the sketch you are trying to upload would be helpful: what is its size after compilation? Can you post it? Finally, are you able to upload the example blink sketch?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 16
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm using arduino 1.0.2 but i had also try it on 1.0.3 and 0022 (older version)
I'm sure that i'm using the right port (com3) and avrisp mkII (i don't really know waht it is.
I think my problem isn't the fault of the program because even the blink sketvh isn't working
What "Upload using a programmer" means ?

Thank you
Logged

Rome, Italy
Offline Offline
Sr. Member
****
Karma: 20
Posts: 442
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm using arduino 1.0.2 but i had also try it on 1.0.3 and 0022 (older version)
I'm sure that i'm using the right port (com3) and avrisp mkII (i don't really know waht it is.
I think my problem isn't the fault of the program because even the blink sketvh isn't working
What "Upload using a programmer" means ?

Thank you

The "Upload using a programmer" is an option that allows you to use an external device (even a cable, or another Arduino) to upload a sketch to a target Arduino without using the bootloader. The device in your case (which is also the default, I believe) is the avrisp mkll http://www.atmel.com/tools/AVRISPMKII.aspx, but it doesn't really matter since you are just doing a normal upload.

Your problem may indicate errors in the bootloader already installed on your Arduino, in which case you''ll have to follow the instructions for burning a new bootloader (and you'll need a programmer, such as the mkll device). But it could also be a problem with serial communication: your PC is sending data at a faster rate than the Arduino can accept. I wouldn't know how to start (also because I'm not on windows) but I would try to see whether some system setting can prevent transmission at 115200 baud (the rate used by avrdude). I would also try changing the COM port, disconnecting other devices.  
« Last Edit: March 10, 2013, 04:17:44 pm by spatula » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 16
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

first of all thank you for your helping.
I had already try with another computer but the result is still the same so i think is not the rate problem.
For the bootloader, is it the only issue to fix it because it requires to buy other thing and it seems a little complicate whereas i'm a beginner.
Do you thing that this problem may be consider as a support problem such as i could use the warranty ?
Thank you
Logged

Rome, Italy
Offline Offline
Sr. Member
****
Karma: 20
Posts: 442
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Do you thing that this problem may be consider as a support problem such as i could use the warranty ?

I have no idea, really smiley-sad.
Logged

Pages: [1]   Go Up
Jump to: