Pages: 1 [2]   Go Down
Author Topic: RC Timer servo--why it just runs when give it power  (Read 1436 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 14
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, one more crucial question: how do I connect that 6V battery to breadboard? Thanks
Logged

UK
Offline Offline
Tesla Member
***
Karma: 141
Posts: 8015
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have just been re-reading your initial post. You don't say whether the problem only exists with one servo or if it happens with others as well?

Do the wiring as has been suggested and write a short Arduino sketch that just does servo.attach(pin) in setup() then connect your servo and report what happens. Also see what happens if you reboot the Arduino while the servo is connected.

I expect that this short code will make the servo arm move to about its middle position.

...R
Logged

UK
Offline Offline
Tesla Member
***
Karma: 141
Posts: 8015
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

That battery and charger should work fine.

You don't need more volts just because you have more servos. More than 6 volts will damage the servos. If you have more servos you need more amps.

Connect the battery to the breadboard with some single-core wire that can be plugged into the breadboard holes. Just make sure not to mix up the positive and negative. (I'm assuming there is no risk of the wire being accidentally pulled out).

...R
Logged

0
Offline Offline
Sr. Member
****
Karma: 8
Posts: 394
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The lead acid battery is fine for bench testing, but probably too heavy for a moving small robot.  For the actual robot LiPo (Lithium polymer) or NiMH should be used.  Lithium's are now the batteries of choice.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 14
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi Robin2 and Joe,
Thanks for help. Regarding Robin2 question:
>>I have just been re-reading your initial post. You don't say whether the problem only exists with one servo or if it happens with others as well?
the main problem was on all the servos. I tried one by one, all of them have same problem.

Now I read all of the posts and tried the new wire arrangement, well not lucky either: I don't have 4 battery pack, I have 3 battery pack which I tried but nothing worked. The servo just does not move at all or give the buzzing sound.

So I plug in this power with LED and upload led program. the led is not lighting. I am sure the battery are new. Could it be battery pack has problem:
I have attached my wiring.  I don't know which line on battery is positive or negative, so I just switched the wire to try. neither way works.Is the wiring wrong?
If wrong, please correct me.



* wire.JPG (632.6 KB, 1632x1224 - viewed 25 times.)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 14
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi Joe, thanks for pointing out the weight issue. I am glad you said it before I buy it and found can't use it. Regarding the one you mentioned
--actual robot LiPo (Lithium polymer) or NiMH --could you give me an Amazon link so I know what you are referring to. And once again, how could you connect that into breadboard--do you have a pic that I can see visually to understand it?

Given all the troubles we have now, I am thinking to go back to the cheap turniGY servo which at least works with power from arduino. I am desperate now. Thanks.
Logged

UK
Offline Offline
Tesla Member
***
Karma: 141
Posts: 8015
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I don't understand why you say you don't know which battery wire is positive or negative. Batteries are always clearly marked.

In the photo you have a 3-battery box with only 2 batteries in it. Unless you have a wire to join the connectors where the 3rd battery should be you will have no output from that.

If you haven't already got one buy a cheap digital multimeter first thing. It will allow you to check voltages and continuity along wires and save you hours of frustration.

You need 4.5v to 6v (not more, not less) to work a servo. That means 3 or 4 AA batteries for testing - they won't last long in a finished model. Make sure all the AA batteries are in good condition - if in doubt get new ones and mark them so you know which ones are new.

The wiring of the servos is very straightforward. The positive from the battery goes to the middle wire in the three-pin/socket servo connector. The negative from the battery goes to the black wire on the servo connector AND to the GND connection on your Arduino. The control signal from the Arduino pin goes to the third wire of the servo connector.

Have you made the short Arduino sketch that I suggested? There is no point trying anything more complicated until you get that working and understand what is happening.

...R
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 14
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi Robin2, thanks for the info. I suspect that was the reason. Anyway, I will buy a 4-AA pack today and try it. BTW, I educate myself by reading AA wiki and found that AA has
 Alkaline batteries from 1700 mAh to 3000 mAh
Why people here saying if for real running, AA is not enough, has to buy Robot LIPO or another kind of battery? Does that 4xAA has enough current to drive 4 servos or NOT? Thanks.
Logged

0
Offline Offline
Tesla Member
***
Karma: 148
Posts: 9750
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Does that 4xAA has enough current to drive 4 servos or NOT? Thanks.

 4xAA  will power 4 servos, but for how long depends on the load on the servos. I suggest you get rechargeable AA batteries (batteries and charger available at Walmart and most other places).
Logged

Consider the daffodil. And while you're doing that, I'll be over here, looking through your stuff.   smiley-cool

Pages: 1 [2]   Go Up
Jump to: