Go Down

Topic: Aiuto collegamenti per non sbagliare.. (Read 6600 times) previous topic - next topic

PaoloP

Pur con i suoi limiti, puoi sempre utilizzarlo.
--> http://playground.arduino.cc/Main/DS1302

matteociocca

È ma dovrei andare a modificare il codice di molto?
Tanto ormai lo ho ordinato..
Nn vedo l ora di farlo andare sto arduino =)

Brunello

ci sono librerie anche per il DS1302.
"C' è chi legge Guerra & Pace e non ci capisce un tubo vuoto; c'è chi legge l'etichetta delle patatine fritte e ci trova la spiegazione del mondo" (J.S. S. architetto napoletano)

leo72


Adesso aspetto che mi arrivi l'RTC e poi provo a farlo andare, speriamo bene.
Avevo sbagliato ad acquistarlo ho preso un ds1302 invece del 307..


Potevi usarlo lo stesso:
http://playground.arduino.cc/Main/DS1302

matteociocca

L'unica cosa è che per il momento, dato che non sono ferratissimo sull argomento, preferivo non apportate modifiche al codice ma andare a ricreare l hardware corretto..
Anche perché questo prototipo mi serve abbastanza velocemente e quindi preferisco non complicarmi la vita. Per i prossimi, visto che penso di realizzarne altri sempre sulla base di questo andrò a pasticciare anche un po' coi codici magari.

Comunque questo è un controller che mi permette di comandare tre linee di Led , programmando l accensione e l'intensità di ogni linea. I Led sono pilotati da driver con ingresso pwm.

matteociocca

ciao a tutti, rieccomi.

Non ho avuto tanto tempo , oggi mi sono messo a fare i collegamenti ma mi rimane tutto lo schermo blu..
che faccio?

Brunello

dipende....

1) ricontrollare i collegamenti
2) controllare se le impostazioni sullo sketch corrispondono ai collegamenti
3) Verificare che ruotando il potenziometro del contrasto cambi qualcosa
4) ...........
"C' è chi legge Guerra & Pace e non ci capisce un tubo vuoto; c'è chi legge l'etichetta delle patatine fritte e ci trova la spiegazione del mondo" (J.S. S. architetto napoletano)

matteociocca

non c'è il potenziometro.. allora i collegamenti li ho fatti diverse volte.. ho seguito quelli che mi sono stati postati..
ho collegato schermo e rtc i pulsanti non dovrebbe fare niente giusto?  le scritte dovrebbero venire fuori lo stesso..

le uniche differenze che non ho attuato sono la restistenza da 2.2 e quel tondino sul pin 16 del display

PaoloP

Ma non hai il potenziometro per regolare il contrasto del dispaly?

Brunello

Quote
e uniche differenze che non ho attuato sono la restistenza da 2.2 e quel tondino sul pin 16 del display


quel tondino sul pin 16 e' un transistor. Serve per poter accendere e spegnere la backlight, ovvero l'illuminazione dell'LCD

Puoi benissimo farne a meno , ma devi collegare il pin 15 dell'LCD al +5V e il pin 16 a  massa

e il trimmer ( o potenziometro ) per regolare il contrasto ti serve proprio


"C' è chi legge Guerra & Pace e non ci capisce un tubo vuoto; c'è chi legge l'etichetta delle patatine fritte e ci trova la spiegazione del mondo" (J.S. S. architetto napoletano)

matteociocca

A ok io lo collegavo al pin6 dici che è quello?
La luminosità si regola dal programma , però a casa c'è lo il potenziometro.. Serve lo stesso? Se si cm lo collego?

PaoloP

Scheda 11 --> http://arduino.cc/forum/index.php/topic,154549.0.html

Una cosa è la luminosità (simboletto del sole nelle TV) e una cosa e il contrasto (simboletto della luna nelle TV).

matteociocca

ecco fatto seguito lo schema che mi hai postato, messo potenziometro l'unica cosa che non ho messo è la resistenza da 270 sul 15..
Ora mi escono tutti i quadratini bianchi, però niente scritte, neanche helloworld per dire..
Serve per forza quella resistenza?

Brunello

No, la resistenza non serve. puoi collegare il pin 15 direttamente al +5V

pero', visto che hai cambiato collegamento, nel tuo sketch l'assegnazione deve essere cosi'

LiquidCrystal lcd(12,11,5,4,3,2);
"C' è chi legge Guerra & Pace e non ci capisce un tubo vuoto; c'è chi legge l'etichetta delle patatine fritte e ci trova la spiegazione del mondo" (J.S. S. architetto napoletano)

matteociocca

A ok, allora i pin sono stati collegati pari pari solo x usare l esempio helloworld , quando ho provato il mio skatch i pin sono stati collegati spostando i pin che variano ..
Ma niente.. Sicuramente o sbaglio io o c è qualcosa se sbaglio a collegare..
Ke nervi... Argh

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy