Go Down

Topic: Aiuto collegamenti per non sbagliare.. (Read 5854 times) previous topic - next topic

matteociocca

Cavolo cosa può essere, qualsiasi cosa carico mi rimangono tutti i quadratini bianchi.. muovendo il contrasto vanno via ma non si vede niente... i collegamenti provati 100 volte ma sono giusti



PaoloP

Ok.  ;)
Puoi mettere una foto in cui si vedano bene i collegamenti e le saldature, questa è troppo scura.
Controlla, inoltre, che non ci siano contatti tra un pin e l'altro.

matteociocca

Ok allora dopo te la faccio.. Questa l'avevo fatta così x far vedere lo schermo cosa usciva =)


PaoloP

#36
Apr 03, 2013, 10:17 am Last Edit: Apr 03, 2013, 10:25 am by PaoloP Reason: 1
Ho visto dalla foto che l'LCD è un 1602B. Prova a seguire questo tutorial
--> http://www.mauroalfieri.it/elettronica/tutorial-lcd-acm1602b-con-arduino.html
Può essere che i collegamenti rispetto ad un LCD normale siano leggermente diversi.

Il problemi con questo modello risalgono alla notte dei tempi  :smiley-roll-blue: --> http://arduino.cc/forum/index.php?topic=20111.0

astrobeed


Può essere che i collegamenti rispetto ad un LCD normale siano leggermente diversi.


Il collegamento è uguale per tutti i display lcd alfanumerici con controller Hitachi compatibile, ovvero vanno collegati i segnali RS-RW-E e D4-D5-D6-D7, però a seconda del modello e della sua variante i pin possono essere disposti in vari modi, quindi è sempre indispensabile fare riferimento al data sheet del modello/variante che stiamo usando per verificare dove si trovano i vari segnali, pure le alimentazione perché possono risultare invertite.
Come detto molte volte la riga di quadratini, o due righe separate da una spenta nel caso di display a 4 righe, è la classica condizione di display correttamente alimentato, contrasto regolato in modo corretto (se non si vede nulla il contrasto è messo male), ma non inizializzato e basta un solo pin dei segnali messo male, o non collegato (saldatura fredda, contatto fasullo), per ottenere questa condizione.

astrobeed


Il problemi con questo modello risalgono alla notte dei tempi


Dimenticavo, il 99.9 (periodico) dei problemi hardware/software con Arduino, in generale, sono dovuti alla mancata lettura, o comprensione, dei data sheet dei vari componenti utilizzati e alle tante carenze, omissioni, errori (troppi) presente sia nel playground che nel reference di Arduino.

matteociocca

Quindi mi faccio dare i data dal venditore?
Dissaldo e risaldo tutto?

astrobeed


Quindi mi faccio dare i data dal venditore?


Più semplicemente cercare con google la sigla, completa, del tuo display come ho fatto io e il data sheet originale è tra i primi risultati della ricerca, lo trovi in allegato.
Controlla con il data sheet i vari pin del display e come li hai collegati con Arduino, eventualmente modifica come li hai assegnati nello sketch, controlla le saldature perché quello che vedo nelle foto non mi piace per niente.

matteociocca

allora, ho dissaldato e risaldato tutto utilizzando altri fili più decenti.
Fatto ciò il problema persiste..
Ora cerco il data.. dietro c'è scritto 1602f REV:I

PaoloP

Il datasheet è allegato al post di Astrobeed precedente al tuo ultimo.  :smiley-roll:

matteociocca

http://html.alldatasheet.com/html-pdf/229310/POWERTIP/1602-F/383/1/1602-F.html

Questo è il data sheet che ho trovato.. E' uguale a come li ho collegati io ..
Allora io ho collegato:
pin 1 collegato al -
pin 2 collegato al +
pin 3 al centro del potenziometro
pin 4 al pin 12 di Arduino
pin 5 al -
pin 6 al pin 11 di A
pin 11 al pin 5 di A
pin 12 al pin 4 di A
pin 13 al pin 3 di A
pin 14 al pin 2 di A
pin 15 al +
pin 16 al -

matteociocca

#44
Apr 03, 2013, 12:47 pm Last Edit: Apr 03, 2013, 12:51 pm by matteociocca Reason: 1
Non me lo apre , mi dice che è danneggiato..
Comunque dietro al mio display c'è scritto 1602F non 1602B quale devo guardare?
sono uguali no?

Go Up