Go Down

Topic: Avrdude Verifcation failure when using -q switch (Read 1 time) previous topic - next topic

hiduino

I get the verification failures usually when the programmer's sck clock is too fast when the attiny internal clocking set below 1.5 MHz.  You can usually fix this by slowing down the sck clock signal.  A few programmers like the usbtiny can be told to slow down with an avrdude -B option.

Try this:
Code: [Select]
avrdude -c usbtiny -p attiny85 -q -B50 -U flash:w:Tiny85Test.hex



You may need to experiment with bigger numbers -B100, -B250.  Of course it will really slow down the programming the higher you go.

I suspect that that the -q option is removing some delays in outputting the progress bar display info.  So in effect it is speeding up the writing a little bit.



hiduino

Alternatively, if you are not able to use the -B option in avrdude, some programmers do not support that option, or you are not able to add that to the command sequence.  You can try a programmer like the USBasp which will support a hardware jumper setting to use a slow sck clock.  But be aware that there are many different versions of the USBasp and some do not support the hardware jumper setting.


Marvin Martian

I tried the 5.11.1 patch last night but no luck - problem still exists. I have just realised that this is still a 'virginal' Tiny85 - the fuses have not yet been set (due to a possible issue with VisualMicro) so that may have a bearing. it's supposed to be on 8Mhz internal clock but is currently on 1Mhz I think. I'll set teh fuses separately tonigth and see if that changes anything...

hiduino

Were you able to try the -B50 option with avrdude?  That should work with the 1MHz clocking.


Marvin Martian

Literally just tried it - still the same problem

Also burnt the fuses for 8 / 8 and 8 / 1 MHz - still fails at both settings :(


Go Up