Go Down

Topic: Arduino Clone Not Working with Win7 64-bit (Read 3 times) previous topic - next topic


I picked up an Arduino clone made by BETEMCU, and I am having some mixed results. It uses a Prolific PL-2303HX USB chip. I downloaded the most recent PL-2303HX drivers (1.8.0) from prolific.com.tw. If I install on my machine at work, or my laptop at home (both running Windows 7 64-bit...one is Home edition and the other is Enterprise), the driver installs fine, and it recognizes the "Prolific USB-to-Serial Comm Port" when the board is plugged in. When I run the Arduino IDE and try to upload any sketch, it gives me the "not in sync" error. I have also tried the 1.0.3 version drivers, with the same results. Full output using "verbose" is below.

BUT, when I install and run on my Windows Server 2008 R2 (64-bit) machine, it all works just fine. Any ideas why that is, and how I might be able to resolve the issue? Thank you!

         Using Port                    : \\.\COM4
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.


the auto reset may not be functioning, hold down the reset button on the arduino and click upload, let go of the reset button the moment the white text at the bottom of the IDE tells you the sketch size, try it a few times if it fails, its a bit tricky sometimes


Tried that. Did not work. This board has this issue only on Win7 64-bit machines. On my Windows 2008 R2 (64-bit) server, it works just fine. I uploaded a sketch that prints to the serial monitor, and that works fine. If I plug the board into one of these Win7 machines, I can see the data in the serial monitor there. So I know the reset is working, because it works on the Win2008 machine. And I know the connection on the Win7 machines works, because it shows up correctly in Device Manager, AND it talks back in the Serial Monitor. So there is something in Windows 7 that is not playing nicely. Something that is not present on Windows 2008 R2.


Installed VirtualBox running an XP SP3 on my Win7 64-bit box. If I pass the Prolific USB device through to the virtual machine, I see the same behavior where I get the not in sync error. If I instead create a COM port on the virtual box and map it back to the COM port on my Win7 box that has the Prolific USB-to-Serial device, it works!

Is there perhaps a Win7 driver issue? Seems that Win7 is causing some kind of timing issue. Is there a way to create a generic COM1 (for example), and then somehow map that to the COM3 that the Prolific has created? That is essentially what I am doing by using VirtualBox. Thanks!

Louis Davis

Go Up