Pages: [1]   Go Down
Author Topic: Arduino Uno auto-start?  (Read 716 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm sure this is really basic.  But, how can I force Arduino to auto run the program after I connect it to a power source without having to press the reset button?

Thanks in advance.
Logged

Global Moderator
Dallas
Online Online
Shannon Member
*****
Karma: 208
Posts: 12936
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


You don't have to do anything.  As soon as the microcontroller is powered, it starts running.  If you have to press the reset button there is something wrong with the board, your program, or the hardware you've connected to the board.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks.  It makes sense and thats how I thought it worked but the program is not running after I connect it...

Now it's going to be more difficult to find out what's going on.

Thanks anyway.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ok, after making some test I can see that the problem is that the ethernet module is not loading properly.  I'm using the Ethernet Shield W5100.  Is there any know issue with the shield or should I keep looking through my code?
Logged

Global Moderator
Dallas
Online Online
Shannon Member
*****
Karma: 208
Posts: 12936
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


I can't help with that one.  If you don't get a reply within a few days, create a new thread.
Logged

Pages: [1]   Go Up
Jump to: