Pages: [1]   Go Down
Author Topic: delay bei 1-wire  (Read 525 times)
0 Members and 1 Guest are viewing this topic.
Lost in Singapore
Offline Offline
Jr. Member
**
Karma: 3
Posts: 74
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

So servus,

dieses delay(1000) macht die one wire Geschichte ziemlich langsam. Soweit ich weiß, brauch ich das delay, um den Kondensator des Gerätes zu laden. Wenn ich allerdings Vcc angeschloßen habe kann ich mir das doch komplett sparen oder?

Danke und Gruß
Logged


Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 252
Posts: 21283
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Falls Du einen DS18S20 hast, kannst Du ihn auch über den 3. Anschluß mit Spannung versorgen.

Grüße Uwe
Logged

Offline Offline
Sr. Member
****
Karma: 8
Posts: 359
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,
ich würde es an deiner Stelle mal austesten. Ich habe mehrer 18B20 im Betrieb und noch nie
ein Problem mit delay(100) gehabt. Das reicht alle Male aus.
Gruß
 
Logged

Lost in Singapore
Offline Offline
Jr. Member
**
Karma: 3
Posts: 74
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Wieviele 1-Wires hattest du dran? Und wie war dein Netzwerk aufgebaut? Welcher Modus parasitär oder normal?
Logged


Offline Offline
Sr. Member
****
Karma: 8
Posts: 359
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

angeschlossen hab ich 8 Stück und Betrieb parasitär, also ohne eigene Stromversorgung.
Logged

Pages: [1]   Go Up
Jump to: