Go Down

Topic: Lilypad usb and Windows 8 trouble (Read 1 time) previous topic - next topic

fayshaw

I'm having trouble connecting my lilypad usb to my Windows 8 machine.  It shows up as an unknown device.  I have tried to install the FTDi drivers, but windows won't install them.  Any advice for this combination?  The lilypad works with a mac.

For clarity, this is the kind of lilypad I have.
https://www.sparkfun.com/products/11190

Louis Davis

This version of the Lilypad does not use the FTDI chip, that is why installing the FTDI drivers is not working.
http://arduino.cc/en/Main/ArduinoBoardLilyPadUSB

First, make sure you get Arduino 1.0.4, so you don't have to worry about signed drivers.

After downloading and extracting 1.0.4 to a folder, follow these steps to install the driver:

Right click the Unknown Device in Device Manager
Select Update Driver Software
Select Browse my computer for software
Click Browse button
Select the Drivers folder under the location of your Arduino software installation. (Do not select the FTDI folder inside the Drivers folder)
Click OK
Click Next

fayshaw

Thanks for the response, but it doesn't work.  When I choose the drivers folder, I get "Windows could not find driver software for your device."  When I choose "Let me pick from a list of device drivers on my computer" I choose "LilyPad Arduino USB", and my computer crashes.

Louis Davis

What is the Hardware ID for the Unknown Device?

Go to Device Manager
Right Click Unknown Device
Select Properties
Select Details tab
Change Property to Hardware Ids
What is displayed under Value?

fayshaw

Under Value it says "USB\DEVICE_DESCRIPTOR_FAILURE".

Louis Davis

Each time I have heard of someone with that error, it has been a bad quality USB cable.

Try another USB cable.

hiduino

I've had similar problems with my Leonardo and Micro when using USB3.0 ports on my laptop.  It worked fine when using a USB2.0 port.  Do you have any available USB2.0 ports to try?


fayshaw

It turns out that the ports on my windows 8 machine are usb 3.0.  Hopefully, switching to a different windows machine will help.  Thanks for the tip.

(P.S. I switched out the usb cable, but there was no change.)

Go Up