Go Down

Topic: Scan 433Mhz (Read 1 time) previous topic - next topic

alb12

Bonjour,
je viens de recevoir mon Arduino uno aujourd'hui, après avoir fait un rapide petit projet  allumer, faire clignoter une led, je souhaiterai maintenant pouvoir écouter les ondes 433mhz autour de moi.
Pour cela je posséde un récepteur 433 Mhz, j'ai essayé d'écouter les ondes que je pouvais capter mais rien.
Quelqu'un pourrait-il m'aider?
Merci d'avance.

Artouste


Bonjour,
je viens de recevoir mon Arduino uno aujourd'hui, après avoir fait un rapide petit projet  allumer, faire clignoter une led, je souhaiterai maintenant pouvoir écouter les ondes 433mhz autour de moi.
Pour cela je posséde un récepteur 433 Mhz, j'ai essayé d'écouter les ondes que je pouvais capter mais rien.
Quelqu'un pourrait-il m'aider?
Merci d'avance.

Bonjour

ton recepteur c'est quoi exactement ?

Qu'est ce que tu "entend"  :smiley-mr-green: exactement par écouter les ondes avec un arduino ?

associé avec un recepteur RF (433) un arduino peut eventuellement decoder si il connait les protocoles, mais pas faire de l'ecoute au sens propre du terme

tu souhaiterais faire quoi exactement ?



alb12

Mon récepteur est celui-ci http://shop.snootlab.com/composants/145-recepteur-rf-434-mhz.html

En fait je souhaite récupérer la température envoyée par une sonde de température, j'ai trouvé le code pour l'arduino ici :http://aberntsen.nl/harm/tnet/1268154/temperaturetoconsole.pde
Le problème est que je n'ai aucun retour de température.
Je voulais donc essayer de faire afficher tout ce que reçois mon récepteur.
Si le code contient une erreur pourriez vous m'aider?
Merci d'avance

Tirmit

envoi ton code pour voir à quoi il ressemble stp

Artouste


Mon récepteur est celui-ci http://shop.snootlab.com/composants/145-recepteur-rf-434-mhz.html

En fait je souhaite récupérer la température envoyée par une sonde de température, j'ai trouvé le code pour l'arduino ici :http://aberntsen.nl/harm/tnet/1268154/temperaturetoconsole.pde
Le problème est que je n'ai aucun retour de température.
Je voulais donc essayer de faire afficher tout ce que reçois mon récepteur.
Si le code contient une erreur pourriez vous m'aider?
Merci d'avance

bonsoir
1ere question à se poser, les infos envoyées par la sonde sont elles compatibles avec le protocole de décodage utilisé par l'arduino ,

quelle sonde ?

chabot380

salut

Et Snootlab ne dit pas si c'est en AM ou en FM ! :smiley-roll:
ORDINAUSORE 2Ghz AMD64 QUI S'ALLUME EN 48 SECONDES AVEC UBUNTU 12.04
ARDUINO UNO / Shield Ethernet / RTC DS1307
Programmation Python et j'apprends le C
Technicien Télé Vidéo à la retraite.

SesechXP

Salut,

La doc du module est ici. Démodulation ASK.
Julien - www.idreammicro.com

infobarquee


salut

Et Snootlab ne dit pas si c'est en AM ou en FM ! :smiley-roll:


tu crois qu'à ce tarif c'est du FM? ;)

@SesechXP
si tu nous montrais ta sonde, marque, etc...
ca serait quand même mieux.
ce module fonctionne très bien avec une ws2355 mais en 433mhz
jete un oeil ici http://www.practicalarduino.com/projects/weather-station-receiver

SesechXP

#8
Mar 17, 2013, 11:00 am Last Edit: Mar 17, 2013, 11:02 am by SesechXP Reason: 1


@SesechXP
si tu nous montrais ta sonde, marque, etc...
ca serait quand même mieux.
ce module fonctionne très bien avec une ws2355 mais en 433mhz
jete un oeil ici http://www.practicalarduino.com/projects/weather-station-receiver


Je ne suis pas l'auteur du sujet :smiley-mr-green: Mais c'est vrai que sans savoir de quelle sonde il s'agit on risque de tourner en rond un moment...

Par contre j'utilise ce même récepteur avec des sondes Oregon Scientific...
Julien - www.idreammicro.com

alb12

Ma sonde de température est celle-ci: http://aberntsen.nl/harm/tnet/1268154/weerstation_thumb.jpg
J'ai trouvé le code pour l'arduino ici mais celui-ci ne me retourne rien : http://aberntsen.nl/harm/tnet/1268154/temperaturetoconsole.pde
Lorsque je tente de faire une Serial.println("test") en debut de fonction checkTemp la console m'affiche en boucle test mais au bout d'un moment s'arrête et la derniere ligne affichée peut etre te (manque donc st ) ou t ( et manque est) et la led orange avec la lettre L n'est plus allumée.
Quelqu'un peut il m'aider à comprendre.
Merci d'avance

Go Up