Go Down

Topic: Windows recognizes Arduino but wont assign COM port (Read 2 times) previous topic - next topic

ukeri

Hello all,

I am having a problem with my Windows 7 assigning a COM port to the Arduino.  I have tried the sticky posts in this section and still no help.  What I have done is open device manager in windows, look at COM ports (which the Arduino shows up) and see the Arduino connected.  However, there is no COM port associated with the Arduino.  I went into the advanced settings to give it a port number, and when I click assign to COM port 4, windows errors out on me.  I plugged my Arduino into another computer and there were no problems communicating with it. 

I was wondering if anyone else has gotten this error and if they can give me any advice to help solve my problem.

Thanks,
Matt

/dev

I was having the same symptom, but your problem might have a different cause.  Here's an excerpt from a very long and boring story about what worked for me:

Quote
...the VCP drivers from FTDI (CDM 2.08.24 WHQL Certified) are nice and signed.  They install successfully, and Device manager shows a new entry "ATmega16U2" under a new class "Atmel USB Devices".  No yellow exclamation mark, and its properties look good.


Maybe it'll work for you...

Cheers,
/dev

Louis Davis

The ATmega16U2 does not need/use FTDI drivers.

The only reason your ATmega16U2 showed up in device manager after trying to load the FTDI drivers, is that during the FTDI install, it caused Windows to re-enumerate the devices.

I suspect you had installed FLIP from Atmel before doing this and the re-enumerate caused Windows to find the Atmel DFU drivers in the FLIP package.

/dev

Thanks, Louis, that's a great explanation of why it worked.  Are you referring to finding FLIP's usb/ia64/libusb0.*?  I may have to go back and unintall VCP and put the 16u2 back into DFU mode to verify this.  Shoot, I can erase 'em back to state they were in when I received them.

In the meantime, what should ukeri do?

Cheers,
/dev

Louis Davis

I would suggest trying the IDE installer created by Eried:
http://arduino.cc/forum/index.php/topic,118440.0.html

Alot of people have had good results with his installer.

Go Up