Go Down

Topic: pic4 (Read 535 times) previous topic - next topic

vasudev

pic4:

MAS3

#1
Mar 16, 2013, 11:22 am Last Edit: Mar 16, 2013, 03:16 pm by MAS3 Reason: 1
Hi and welcome to this forum.
You have been posting in at least 2 other threads that aren't about your problem and that aren't finished yet.
That's not a nice thing to do, you're breaking into those threads with your problem.
That's the reason why i'm answering here in the thread you accidentially started, trying to reply in another thread by posting a picture.
Maybe a moderator can move those postings into this thread to tidy up the other threads.

Looks to me your display is working just fine.
It is trying to display everything you are sending it, but you don't leave it enough time to do so.
A LCD linke this, needs some time to switch pixels and you need some more time to register them with your eyes.
So write to your display, and then wait a bit.
Maybe something like 100 or 200 milli seconds, and best is to do something else in that time but that's up to you.
Keep in mind that you have 2 rows of 16 characters you can write to so don't send too much (it will probably disappear as the controller is able to process much more characters).

If you are trying to update lines with different info, you can do such updates by placing the cursor at the right location and just update that section instead of the whole line.
As a practice and a speedtest to your display you could also write to different secctions of that display in deferent speeds.
That way you'll find the best update rate for your display.

(edited: removed some typo's)
Have a look at "blink without delay".
Did you connect the grounds ?
Je kunt hier ook in het Nederlands terecht: http://arduino.cc/forum/index.php/board,77.0.html

Go Up