Pages: [1]   Go Down
Author Topic: !!!Brauche Hilfe!!!  (Read 1931 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 70
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,

kann mir einer sagen ob ich mit einem arduino leonardo einen bootloader auf ein ATMEGA8-16P bekomme??
Wenn ja wie ?
Ich habe auch einen "mySmartUSB light" zuhause liegen könnte es damit gehen ??

Ich bin auf eure Hilfe angewiesen !
Ich freue mich über JEDEN tipp !
Logged

Switzerland
Offline Offline
Faraday Member
**
Karma: 111
Posts: 5242
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
kann mir einer sagen ob ich mit einem arduino leonardo einen bootloader auf ein ATMEGA8-16P bekomme??

Ja, müsste in etwas gleich funktionieren, wie mit einem UNO. Die entsprechenden Anleitungen müssten funktionieren.

Was der "mySmartUSB light" sein soll, kann ich Dir ohne Link leider nicht sagen.
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 70
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

http://www.amazon.de/ZEITECH-ART2491-mySmartUSB-light-Programmer/dp/B004CGD8BQ

Danke...ich habe es schon ungafähr 8 mal nach dieser anleitung ausprobiert: http://arduino.cc/en/Tutorial/ArduinoToBreadboard Es kommt immer diese fehlermeldung:
Code:
avrdude: stk500_getsync(): not in sync: resp=0x00
Logged

Cologne
Offline Offline
God Member
*****
Karma: 11
Posts: 512
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

mach es mit dem mySmartUSB light, den hab ich auch.
Dazu musst du folgendes in die Datei programmers.txt eintragen, einfach am Ende anhängen.
Code:
mySmartUSB.name=mySmartUSB
mySmartUSB.communication=serial
mySmartUSB.protocol=stk500v2
Danach die IDE neu starten. Im Menue unter Tools->Programmer müsstest du den mySmartUSB auswählen können.
Den mySmartUSB mit dem Atmega verbinden, das richtige Board in der IDE einstellen und Burn Bootloader.
That's it.
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 70
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Danke,

ich habe es genauso gemacht...aber ich bekomme immer diese fehlermeldung:
Code:
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override

Spielt es eine rolle ob ich den atmega mit einem anderen arduino die spannung liefere oder muss es mit dem "mySmartUSB light" sein ?

kann es sein das ich die schaltung verbockt habe ?


* 20130325_235740.jpg (2968.03 KB, 3264x2448 - viewed 35 times.)
Logged

Switzerland
Offline Offline
Faraday Member
**
Karma: 111
Posts: 5242
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Die Glättungs-/Puffer-Kondensatoren fehlen. Mach zwischen Vcc und GND einen 100nF und einen 47µF Kondensator rein. Ohne die kriegst Du den Bootloader wahrscheinlich nicht drauf (nach meiner Erfahrung).
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 70
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Danke,

ich habe einen 100nf kondensator zwischen +5v und gnd gesteckt...es erscheint immer noch die gleiche fehlermeldung....

Könnte es sein das der atmega8-16p von dem vielen ausprobieren kaputt gegangen ist ?
Logged

Switzerland
Offline Offline
Faraday Member
**
Karma: 111
Posts: 5242
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
ich habe einen 100nf kondensator zwischen +5v und gnd gesteckt...es erscheint immer noch die gleiche fehlermeldung....

In meinem Satz war ein "und" und kein "oder". Wo ist der 47µF (oder grösser)?

Quote
Könnte es sein das der atmega8-16p von dem vielen ausprobieren kaputt gegangen ist ?

Wir können das nicht ausschliessen, da wir nicht wissen, was Du alles gemacht hast.

Hast Du mal versucht, mit Deinem Programmer den Bootloader des Leonardo neu zu schreiben? Funktioniert das denn überhaupt schon? Es könnte ja sein, dass Dein Programmer nicht richtig tut.
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 70
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,

als erstes wollte ich mich dafür entschuldigen das ich zwei mal die gleiche frage reingestellt habe, aber ich bin neu hier in dem forum und kenne mich noch garnicht aus!

Ich besitze keinen 47µF kondensator ich bin ein einsteiger ich habe noch relativ wenige bauteile! Kondensatoren habe ich nur noch:
2 X 100nF
2 X 22pF

Wahrscheinlich kommt der "mySmrtUSB light" nicht mit arduino klar, denn ich konnte den bootloader nicht auf mein arduino leonardo board installieren können ich habe wieder eine fehlermeldung bekommen.

Ich habe einen 10K ohm zwischen reset und +5V ist das richtig ?? oder muss ich den herrausnehmen wenn ich den bootloader installieren will ?

Ich bedanke mich an allen die mir schon tipps oder lösungs vorschläge gegeben haben!
Logged

Germany
Offline Offline
Edison Member
*
Karma: 48
Posts: 2338
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Wenn du versuchst, den Bootloader mit dem ISP auf den Arduino zu brennen, benötigst du keine weiteren Bauteile. Wenn das Brennen des Bootloaders mit dem ISP dann immer noch nicht klappt (auch den Leonardu in der Liste auswählen!), so ist dein mySmartUSB light nicht richtig eingebunden bzw. konfiguriert. In dem Fall ist auch das Programmieren des angesprochenen Atmega8 aussichtslos.
Logged

Mein Arduino-Blog: http://www.sth77.de/ - letzte Einträge: Teensy 3.0 - Teensyduino unter Window 7 - Teensyduino unter Windows 8

Offline Offline
Edison Member
*
Karma: 21
Posts: 1419
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hast Du denn für den mySmartUSB light einen Treiber installiert und erscheint in der Geräteliste eine neue serielle Schnittstelle, wenn Du den Programmer ansteckst?
Hier wird ziemlich viel durcheinander getestet, das ist in der Regel wenig hilfreich.
Erstmal sollten die Grundvorausserzungen geprüft werden, ehe man anfängt am eigentlichen Problem zu arbeiten.

- Welches Betriebssystem ? (inkl. Angabe ob 32bit oder 64bit)
- Welche Version der IDE?
- prüfen ob im Gerätemanager (falls Windows) Geräte auftauchen, zu denen Fehler gemeldet werden
- ist (wenn es ein Windows ist) z.B. sowas wie Bluetooth aktiv, oder andere serielle Geräte die stören könnten?
 
Sollte die Hardware verfügbar sein und kein Treiber fehlen, könnte man z.b. erstmal mit avrdude prüfen, ob der Programmer antwortet.

Mario.
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 70
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,

ich habe es geschafft danke an alle die mir geholfen haben aber der entscheidende tipp war von "sth77" ich habe alle bauteile abgesteckt also quarz, kondensatoren und den widerstand dann habe ich es nocheinmal mit dem "mySmartUSB light" programmer versucht...ich habe sofort die meldung bekommen: "Bootloader wurde installiert"
Logged

Germany
Offline Offline
Edison Member
*
Karma: 48
Posts: 2338
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

... aber der entscheidende tipp war von "sth77" ich habe alle bauteile abgesteckt also quarz, kondensatoren und den widerstand ...
Hatte ich so eigentlich nicht gemeint, sondern dass du sämtliche (lose, nicht festgelötete) Beschaltung am Leonardo-Board abnimmst. Aber wenns nun trotzdem klappt, klopfe ich mir erst mal selbst 'ne Runde auf die Schulter. smiley-wink
Logged

Mein Arduino-Blog: http://www.sth77.de/ - letzte Einträge: Teensy 3.0 - Teensyduino unter Window 7 - Teensyduino unter Windows 8

Pages: [1]   Go Up
Jump to: