Pages: [1]   Go Down
Author Topic: Problem mit I2C LCD  (Read 857 times)
0 Members and 1 Guest are viewing this topic.
Europe / Germany
Offline Offline
Sr. Member
****
Karma: 11
Posts: 345
keep it simple
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Guten Morgen, es geht um dieses LCD Modul: http://www.komputer.de/zen/index.php?main_page=product_info&cPath=30&products_id=49

Anschluss am Uno laut Wiki: SDA 4, SCL 5, +5V, GND

Lib installiert, Example getestet, keine Anzeige auf LCD. Adresse auf LCD und im Sketch geändert, nichts.

LCD hat Spannung, Kontrast stimmt (obere Zeile zeigt gefüllte Rechtecke an).

I2C Scanner getestet http://playground.arduino.cc/Main/I2cScanner : nichts gefunden.

Mit Jumpern am LCD gespielt (Adresse geändert) - nichts gefunden vom Scanner.

Was habe ich übersehen?

Gruß Helmuth
Logged

Germany S-H
Offline Offline
Faraday Member
**
Karma: 146
Posts: 3040
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Was habe ich übersehen?

Diesen erst vor fünf Tagen gelaufenen Thread:
http://arduino.cc/forum/index.php?topic=154376.0
Logged

Forum Moderator
BZ (I)
Online Online
Brattain Member
*****
Karma: 266
Posts: 21664
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ich hoffe Du hast A4 und A5 verwendet und nicht D4 und D5. Alternativ kannst Du auch die letzten 2 Pins nach Aref verwenden. Auf der Unterseite sind diese Pins beschriftet.
Grüße Uwe
Logged

Europe / Germany
Offline Offline
Sr. Member
****
Karma: 11
Posts: 345
keep it simple
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi jurs,

das hilft auch nicht. Delay vor und nach init, 2x init, Reset im Betrieb, ... nix.

Dem I2C Scanner sollte das ja auch egal sein, ob das Display mitkommt - die I2C Kommunikation an sich kommt nicht zustande, jedenfalls wird kein Device erkannt.

Habe auch schon mit anderem UNO und anderem Kabel experimentiert - keine Veränderung.

Habe anstelle des LCD Moduls auch mit identischem I2C Controller allein getestet: http://www.komputer.de/zen/index.php?main_page=product_info&cPath=30&products_id=221

Der I2C Scanner findet nach wie vor nichts.

@Uwe: Ich habe mich bisher an dieses Wiki gehalten -http://www.dfrobot.com/wiki/index.php/I2C/TWI_LCD1602_Module_%28SKU:_TOY0046%29, also D4 und D5...

edit: Achso, der Scanner braucht A4 und A5. Das war mir entgangen. Jetzt bleibt der Scanner bei "scanning" stehen.
« Last Edit: March 20, 2013, 03:32:13 am by Helmuth » Logged

Germany S-H
Offline Offline
Faraday Member
**
Karma: 146
Posts: 3040
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

@Uwe: Ich habe mich bisher an dieses Wiki gehalten -http://www.dfrobot.com/wiki/index.php/I2C/TWI_LCD1602_Module_%28SKU:_TOY0046%29, also D4 und D5...

edit: Achso, der Scanner braucht A4 und A5. Das war mir entgangen. Jetzt bleibt der Scanner bei "scanning" stehen.

Oh, oh, ein falsches Verdrahtungsbild auf der Seite!

A4 und A5 sind die Leitungen beim UNO, und zwar nicht nur für den Scanner, sondern für alle I2C Hardware!

Wo bei welchem Board SDA und SCL liegen, steht immer in der Boardbeschreibung, also ggf. nochmal nachlesen:
http://arduino.cc/en/Main/arduinoBoardUno
Logged

Europe / Germany
Offline Offline
Sr. Member
****
Karma: 11
Posts: 345
keep it simple
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Verdammt, tolle Doku vom Hersteller. Also, der externe Controller wird jetzt erkannt, der mit LCD dran nicht...

Habe ihn wohl zerschossen durch zusammenschalten von Ausgängen?!
Logged

Forum Moderator
BZ (I)
Online Online
Brattain Member
*****
Karma: 266
Posts: 21664
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

A4 und A5 sind die Leitungen beim UNO, und zwar nicht nur für den Scanner, sondern für alle I2C Hardware!

Wo bei welchem Board SDA und SCL liegen, steht immer in der Boardbeschreibung, also ggf. nochmal nachlesen:
http://arduino.cc/en/Main/arduinoBoardUno

... und bei R3 Versionen ist es auch aufgedruckt. Sieh mal die Unterseite an.
Grüße Uwe
Logged

Pages: [1]   Go Up
Jump to: