Go Down

Topic: 1284p Ethernet Shield (Read 6013 times) previous topic - next topic

skorpi08

wenn der 1284 angeschlossen ist, sind es 3.84V. Wenn nur das Ethernet Shield angeschlossen ist, sind es 4.20V. Gemessen wurde an dem ICSP. Das UNO Board gibt 4.88V ab ohne dass was angeschlossen ist.

Ich wüsste sonst nicht wo man die 12 V anschließen könnte aber das "auch" gehörte einfach zum Satz :D
Nicht Mensch, nicht Tier: Programmierer halt...

pylon

Ich habe keine Ahnung, wieso bei Dir gleich die Spannung zusammenbricht, wenn (kleine) Verbraucher angeschlossen werden, aber da stimmt etwas nicht. Hast Du sonst noch eine stabilisierte 5V Spannungsquelle, die ein paar hundert mA liefern kann?

skorpi08

#32
Mar 22, 2013, 01:33 pm Last Edit: Mar 22, 2013, 01:36 pm by skorpi08 Reason: 1
ok, nun läuft das Ethernet Shield aber nicht mit SD Karte. Welche PINs brauch die SD Karte? Habe PIN 4 an PB0 und PA0 probiert aber...
Code: [Select]
Free RAM: 14572
Setting up SD card...
card failed
vol.init failed!
openRoot failedSetting up the Ethernet card...
Web server starting...
Ready to accept HTTP requests.


Mit UNO läuft das natürlich.

EDIT// Hier der Sketch http://pastebin.com/mFpQVK1N
Nicht Mensch, nicht Tier: Programmierer halt...

mkl0815

Schön, das Dein Ethernet-Shield jetzt funktioniert. Wie hast Du es denn nun endgültig angeschlossen und das Spannungsproblem gelöst. Falls jemand ein ähnliches Problem hat.

skorpi08

Ehrlich gesagt hab ich nichts anders gemacht wie die letzten Tage auch  :smiley-red:
Am ICSP: MOSI, MISO, SCK, GND, VCC mit
   1284p: PB5,  PB6,   PB7, GND, VCC verbunden. Der PIN 10 am Ethernet Shield sollte laut Datenblatt an PB4 aber funktioniert nur an PB2.
AREF und RESET muss dazu nicht angeschlossen werden.
Die 100nF müssen auch nicht sein (zumindest Funktioniert auch ohne)

Die SD Karte ist nun mein nächstes Problem.
Nicht Mensch, nicht Tier: Programmierer halt...

pylon

Quote
Der PIN 10 am Ethernet Shield sollte laut Datenblatt an PB4 aber funktioniert nur an PB2.


Welches Datenblatt? Der entsprechende Port wird in der Bibliothek ausgewählt und für alle nicht speziell aufgeführten Prozessoren wird Port B2 genommen (Fallback).

Quote
Die SD Karte ist nun mein nächstes Problem.


Welchen Pin gibst Du denn als CS an? Ausser dem CS müssen wie bei Ethernet SCKL, MISO und MOSI verbunden sein. Dazu Masse und Stromversorgung.

skorpi08

Laut meinem Sketch
Quote
// pin 4 is the SPI select pin for the SDcard
const int SD_CS = 4;

Nicht Mensch, nicht Tier: Programmierer halt...

pylon

Dann muss Pin 4 vom Ethernet Shield an PB4.

skorpi08

Am ICSP: MOSI, MISO, SCK, GND, VCC mit
   1284p: PB5,   PB6,   PB7, GND,  VCC verbunden. PIN10 an PB2 und PIN4 an PB4.

die gleiche Ausgabe:
Code: [Select]
Free RAM: 14572
Setting up SD card...
card failed
vol.init failed!
openRoot failedSetting up the Ethernet card...
Web server starting...
Ready to accept HTTP requests.
Nicht Mensch, nicht Tier: Programmierer halt...

pylon

Welcher Sketch liefert diese Ausgabe?

Blöde Frage, aber: Die SD-Karte ist im Slot und kann vom UNO aus angesprochen werden?

skorpi08

#40
Mar 22, 2013, 04:01 pm Last Edit: Mar 22, 2013, 04:10 pm by skorpi08 Reason: 1
Das Leben kann so schön sein...

Quote
Mit UNO läuft das natürlich.

Hier der Sketch http://pastebin.com/mFpQVK1N


SD ist natürlich drin.
Library TinyWebServer

EDIT: So siehts mit UNO aus
Code: [Select]
Free RAM: 404
Setting up SD card...
Setting up the Ethernet card...
Web server starting...
Ready to accept HTTP requests.
Nicht Mensch, nicht Tier: Programmierer halt...

pylon

Was ist der Wert von card.errorCode() wenn die Initialisierung schief geht?

skorpi08

Serial << F("Der Karten Fehler ") << card.errorCode() << "\n";

Gibt eine 0
Nicht Mensch, nicht Tier: Programmierer halt...

pylon

Du hast also

Code: [Select]
  if (!card.init(SPI_FULL_SPEED, 4)) {
    Serial << F("card failed\n");
    Serial << F("Der Karten Fehler ") << card.errorCode() << "\n";
    has_filesystem = false;
  }


in Deinem Code und das ergibt  eine 0? Das kann eigentlich nicht sein, ich hab's allerdings nur für die aktuelle IDE überprüft (1.0.4).

skorpi08

Öhm ne, sorry. Egal an welchen PIN ich PB4 oder PB0 stecke, zeigt Fehler 1 an. Auch wenn ich die SD Karte nicht rein stecke, ist Fehler 1

Was heißt das nun?
Nicht Mensch, nicht Tier: Programmierer halt...

Go Up