Go Down

Topic: Problems with Uploading a Sketch [solved] (Read 1 time) previous topic - next topic


Coding Badly

• Shutdown the computer
• Disconnect the Arduino
• Boot the computer
• Start Device Manager
• Ensure nothing is connected to the Arduino except the USB cable
• Connect the Arduino to the computer

Is the device insertion sound generated?

Does the Arduino appear in Device Manager under Ports?

• Start the Arduino IDE
• Ensure the correct board and serial port are selected
• Load a simple sketch like Empty or Blink
• Upload

What is the exact error message?


Is the device insertion sound generated?


Does the Arduino appear in Device Manager under Ports?

Prolific USB-to-Serial Comm Port (COM5); no ports heading appeared until the Arduino was connected. After the device insertion sound, then the Proli<snip>OM5) appeared under Ports. When I last checked, it stays under the Ports heading until reboot.

What is the exact error message?

Done uploading
Binary sketch size: 1,084 bytes (of a 32,256 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x30

Thank you

Louis Davis

If you have a Prolific USB to serial device, then you don't have a genuine Arduino UNO. You have a clone.

The problem with clones is that you don't know what bootloader is installed and if the board was made properly.

You should also make sure you have the latest drivers for the Prolific USB to serial device:


Thanks for the excellent post; problem solved. Yes, my Arduino is self-made a clone. I have an ATMega168 with no bootloader, and that seems to have been mixed in with the ATMega328s that do have the bootloader. The bigger problem was that I missed a contact when I soldered the socket into place. Once that was soldered, the ATMega328s were simple to load with my sketch. Thanks very much for your help, all of you.



Go Up