Pages: [1]   Go Down
Author Topic: SD cards blanking during use?  (Read 308 times)
0 Members and 1 Guest are viewing this topic.
UK
Offline Offline
Sr. Member
****
Karma: 0
Posts: 273
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

I have an increasing experience of SD cards blanking themeselves, and causing an error, during use - wonder if anyone else has had the same or similar?

The (3V3) Arduino is logging every 5 minutes and has the SD card mounted about 10cm from the Arduino itself - this is simply a card holder with the 6 important pins connected back to Arduino - 3V3, GND, MOSI, MISO, CS & SCK.

Everyting works fine, file creates, data is written etc but sometimes when coming back to it the card is completely blank and Arduino reports a write error - the data can be recovered with recovery software up to the point when the card caused an error..... hmmmm very puzzled - hopefully I have made a simple electonics mistake but look forward to thoughts.
Logged

Miramar Beach, Florida
Offline Offline
Faraday Member
**
Karma: 115
Posts: 5365
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Are you using an Uno and the SD power connected to the 3v3 pin? If so, there may not be enough power available there to write to the SD. It is rated at 50ma, and the SD could use twice that when writing.
Logged

UK
Offline Offline
Sr. Member
****
Karma: 0
Posts: 273
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, I'm using the Arduino 3V3 so this could indeed be the issue - thanks for the tip, I will try some tests to see what happens.  I think it must be very close to being OK as failures are rarer than success :-)  I wonder if putting a capacitor in there somehwere would help as a revevoir and smooth out the write cycle consumption?
Logged

Pages: [1]   Go Up
Jump to: