Pages: [1]   Go Down
Author Topic: Ethernet.begin(mac,ip); no funciona con client.println("GET http://www.google  (Read 696 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Full Member
***
Karma: 1
Posts: 208
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola tras unas cuantas horas trasteando no encuentro sentido.

Es muy facil de explicar si uso Ethernet.begin(mac,ip); no funciona client.println(); sin embargo si uso Ethernet.begin(mac); osea sin la ip si funciona.


Vi en ejemplos como el de WebClientReapeting donde muestran un ejemplo muy parecido donde se usa la ip manual, pero extrañamente no me funciona. Es de la libreria de arduino.


Nota creo que usar ip no deberia de interferir en nada. la pongo por que quiero que sea siempre la misma ip local.


Ethernet.begin(mac,ip); no funciona con client.println("GET http://www.web.es");


Code:
#include <Ethernet.h>
#include <SPI.h>


byte mac[] = { 
  0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED }; //physical mac address
byte ip[] = { 
  192, 168, 1, 20 };            // ip in lan
EthernetServer server(5675);                //server port
EthernetClient client;

//variables
String readString = String(30); //string for fetching data from address
char url[100];     
char meta[200];
void setup()
{

  Serial.begin(9600) ;
  //INTERNET
//  Ethernet.begin(mac);
    Serial.println("cargando");
    Ethernet.begin(mac,ip);
}

void loop(){
  char serverName[] = "www.gestion.ardumotica.es";

  // if there are incoming bytes available
  // from the server, read them and print them:
  if (client.connect(serverName, 80)) {
    Serial.println("conectado");

   
    client.println("GET http://www.gestion.ardumotica.es");
    // Serial.println(url);
    client.println();


  }
  else {
    // kf you didn't get a connection to the server:
    Serial.println("connection failed");
  }

}
Logged


Offline Offline
Newbie
*
Karma: 1
Posts: 47
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Así tal como cuentas y sin leer el código que has puesto me suena a que tienes activado el servidor DHCP en el router, en cuyo caso no puedes asignar la IP manualmente al arduino y por eso te funciona cuando no la especificas en el código.......
Salu2.
Logged

Offline Offline
Full Member
***
Karma: 1
Posts: 208
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

El problema viene cuando no la especifico y quiero utilizarlo como servidor, es decir, una web se conecta a arduino y este manda los datos. No va y si no me equivoco es porque no sabe a que ip resolver el puerto por el que se conecta ya que este está abierto hacia la que lo pongo de forma manual
Logged


Pages: [1]   Go Up
Jump to: