Pages: [1]   Go Down
Author Topic: Problema con rele  (Read 1310 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Buenas noches, soy informático y un novato en temas de electrónica y necesito una pequeña ayudita si fuese posible. Estoy montando con un Arduino UNO un sistema inteligente de riego y con todo ya montado me falla el tema de activar el relé para hacer funcionar la bomba. Tengo un relé de 220V-12A ( http://www.electronicaembajadores.com/Productos/Detalle/-1/RL3A405/rele-convencional-5vdc-spdt-1-c-o-12a-schrack-rt114005) montado siguiendo el esquema que encontré en esta página http://tallerarduino.wordpress.com/2012/07/10/reles-y-arduino-encendiendo-una-bombilla-desde-tu-arduino/, cuando activo el pin digital del arduino sin el relé compruebo con el multímetro y me da 4.90 V, pero en ese mismo punto con el relé enchufado a la placa, la tensión se me baja a 1.60V con lo que el relé no tiene fuerza para activarse, sin embargo en vez de enchufar la salida digital engancho la salida de 5v del arduino el relé enciende. He probado a modificar la resistencia al transistor pero sin resultado, ¿alguna sugerencia? Puede ser que este preguntando una tontería, pero de preguntar se aprende. Gracias de antemano
Logged

Málaga, Spain
Offline Offline
Edison Member
*
Karma: 40
Posts: 2182
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Vas a necesitar un transistor. La corriente máxima que es capaz de suministrar un pin del AVR es de 40mA. Mucho me temo que tu rele supera esto con creces.
Logged

   

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Muchas gracias fm, algo se aprende. ¿conoces algún modelo que me pueda servir?, tengo un bd137 ¿valdría cambiar el que tengo por este otro?
« Last Edit: March 21, 2013, 04:28:38 pm by nando84 » Logged

Málaga, Spain
Offline Offline
Edison Member
*
Karma: 40
Posts: 2182
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Cualquier transistor te valdrá FET o BJT. suponiendo que el modelo que tienes es el que acepta 5VDC a la entrada necesitas suministrarle unos 82mA.
Logged

   

Cordoba
Online Online
God Member
*****
Karma: 38
Posts: 646
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

con un bc547 / 8 / 9 sobra. Revisa las conexiones y no olvides el diodo
Logged

El que pregunta aprende, el que responde aprende a responder.

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Muchas gracias, esta tarde probaré a ver si con este último paso termino el sistema. Gracias fm y maxid
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Buenas tardes, siento haber tardado en probar pero sigo con mis problemillas. He cambiado el transistor porun bd137 y sigo sin activar el relé con un pin digital tal y como indica el tutorial http://www.arduino.cc/es_old/Tutoriales/Rele. Si fuerzo la entrada de 5v en lugar del pin digital si se activa, alguna sugerencia?

Gracias!
Logged

Cordoba
Online Online
God Member
*****
Karma: 38
Posts: 646
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

en que punto fuerzas los 5 volts, antes o despues de la resistencia?, con o sin transistor?
Para ayudarte mejor postea tu codigo, pude haber algun error alli, tambien puede haber otro problema de conexiones.
Lo mas simple es conectra un led para ver si tu codigo funciona, y despues sigues con el rele.
Logged

El que pregunta aprende, el que responde aprende a responder.

Málaga, Spain
Offline Offline
Edison Member
*
Karma: 40
Posts: 2182
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Si ves que funciona con el LED prueba a bajar la resistencia a 470. Es posible que necesites una corriente de base superior. Si no te funciona el LED sospecha de la conexión del transistor o simplemente esta roto.
Logged

   

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Buenas ante todo gracias por las respuestas.

Los 5v los fuerzo antes de la resistencia de 1k y del transistor, lo que hace activar el relé. La señal digital del arduino se activa bien y tras forzar los 5v el relé se mantiene activado hasta que des activo el pin digital, por lo que entiendo que llega algo de intensidad pero no la suficiente como para activarlo y si mantenerlo. Probé también en un intento a no tener resistencia.
Logged

Cordoba
Online Online
God Member
*****
Karma: 38
Posts: 646
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

sin ver tu codigo dificil ayudarte
Logged

El que pregunta aprende, el que responde aprende a responder.

Málaga, Spain
Offline Offline
Edison Member
*
Karma: 40
Posts: 2182
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Una resistencia de 470, no lo pongas sin resistencia en la base del transistor.

El rele para que se mantenga tienes que dejar activado el pin. A no ser que tengas un rele latching.
Logged

   

Pages: [1]   Go Up
Jump to: