Go Down

Topic: Attiny85 Arduino Ide (Read 2593 times) previous topic - next topic

legotechnicus

Hallo,
ich bin neu hier und hoffe, dass ich hier Hilfe für mein kurioses Problem hat.
Also ich habe mir diesen USBasp Programmer gekauft(Ja, ich weiss das der Made in China ist):
http://www.amazon.de/Programmer-herunterladen-Netzteil-Atmel-ATMega/dp/B0093DLN74/ref=sr_1_5?ie=UTF8&qid=1363969233&sr=8-5
Nun möchte ich damit meinen ATTiny85, den ich mit diesem Addon ( http://hlt.media.mit.edu/?p=1695 ) normalerweise mit Arduino als ISP programmiere,
programmieren. Kann ich das in der Arduino IDE machen oder brauche ich AVRdude im Terminal ?(Wenn AVRdude dann bitte wie, verstehe es leider nicht)
Ich arbeite mit Ubuntu 12.10 und mit Arduino IDE 1.0.1 & 1.0.3 .
Weiss da jemand Rat ?

Legotechnicus
Everybody makes mistakes, me too :)

sth77

Avrdude wird ja sowieso aufgerufen, muss nur die richtigen Parameter übergeben bekommen. Versuch es mal so: http://www.chrmoll.de/elektronik/arduino/usbasp
Mein Arduino-Blog: http://www.sth77.de/ - letzte Einträge: Teensy 3.0 - Teensyduino unter Window 7 - Teensyduino unter Windows 8

erni-berni

Wenn du den USBasp als Programmer in die Datei programmer.txt einträgst (wie in dem Link bechrieben), den dann in der IDE auswählst kannst du jedes Programm einfach mit dem Menübefehl "Upload using programmer" hochladen. So kannst du auch die Fusebits setzen. Einfach den Chip auswählen, z.B. ATtiny85 internal 8, dann "Burm Bootloader" und schon werden die Fuses, die ja im Auslieferzustand auf 1MHz stehen umgefused (sorry für dieses denglish).

michael_x

"umgefuset" wäre deutsch gewesen ( geworden ? )

scannen ist z.B. auch Deutsch: Ich scanne, er scannt, wir haben gescannt.

legotechnicus

Dank für die schnellen Antworten.Ich habe alles gemacht aber ich kriege eine Fehlermeldung beim "Uploaden with programmer"

avrdude: Warning: cannot query manufacturer for device: error sending control message: Operation not permitted
avrdude: error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc


Der Befehl lsusb im Terminal hat mir diese Meldung gegeben
Bus 006 Device 002: ID 192f:0916 Avago Technologies, Pte.
Bus 007 Device 002: ID 16c0:05dc VOTI shared ID for use with libusb // ist das der Programmer?
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Everybody makes mistakes, me too :)

legotechnicus

Was bedeutet eigentlich:
avrdude: error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc. ?
Everybody makes mistakes, me too :)

erni-berni

Poste mal die Meldungen, die in den syslog geschrieben werden, wenn du den USBasp einsteckst
Code: [Select]
sudo tail -f /var/log/syslog

mkl0815

Quote
Kann nicht Programm Bootloader Verfahren der AVR einzigen Chip
Inkompatible Notizbücher: Lenovo M7300, Acer 4741G, Dell Vostro3450 und andere Modelle mit Pentium G6950 oder Core i3, i5 Prozessor

Und da wird hier über wenigstens verständliche Worte wie "umgefused" diskutiert  :D

legotechnicus

@mkl0815
Mein Rechner steht nicht auf der Liste.
Apropos : einfach bei Google Übersetzer eingeben und das Englische verstehen  :) :)

@erni-berni
Kann im Moment nicht an den Rechner, werde nächstes Wochenende die Meldung posten

Danke für die Antworten
Everybody makes mistakes, me too :)

legotechnicus

Hi,
hier ist mein Meldung :
Code: [Select]
Mar 30 14:02:01 Rechner-Joshua nullmailer[1378]: Sending failed:  Host not found
Mar 30 14:02:01 Rechner-Joshua nullmailer[1378]: Starting delivery: protocol: smtp host: mail file: 1360929945.3502
Mar 30 14:02:01 Rechner-Joshua nullmailer[1378]: Starting delivery, 9 message(s) in queue.
Mar 30 14:02:01 Rechner-Joshua nullmailer[5342]: smtp: Failed: Connect failed
Mar 30 14:02:01 Rechner-Joshua nullmailer[1378]: Sending failed:  Host not found
Mar 30 14:02:01 Rechner-Joshua nullmailer[1378]: Starting delivery: protocol: smtp host: mail file: 1360853400.3571
Mar 30 14:02:01 Rechner-Joshua nullmailer[1378]: Starting delivery, 9 message(s) in queue.
Mar 30 14:02:01 Rechner-Joshua nullmailer[5343]: smtp: Failed: Connect failed
Mar 30 14:02:01 Rechner-Joshua nullmailer[1378]: Sending failed:  Host not found
Mar 30 14:02:01 Rechner-Joshua nullmailer[1378]: Delivery complete, 9 message(s) remain.
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Rescanning queue.
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery: protocol: smtp host: mail file: 1362165714.4909
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery, 9 message(s) in queue.
Mar 30 14:03:01 Rechner-Joshua nullmailer[5412]: smtp: Failed: Connect failed
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Sending failed:  Host not found
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery: protocol: smtp host: mail file: 1354364114.3835
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery, 9 message(s) in queue.
Mar 30 14:03:01 Rechner-Joshua nullmailer[5413]: smtp: Failed: Connect failed
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Sending failed:  Host not found
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery: protocol: smtp host: mail file: 1361014260.4279
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery, 9 message(s) in queue.
Mar 30 14:03:01 Rechner-Joshua nullmailer[5414]: smtp: Failed: Connect failed
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Sending failed:  Host not found
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery: protocol: smtp host: mail file: 1363281582.5487
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery, 9 message(s) in queue.
Mar 30 14:03:01 Rechner-Joshua nullmailer[5415]: smtp: Failed: Connect failed
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Sending failed:  Host not found
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery: protocol: smtp host: mail file: 1356809348.3411
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery, 9 message(s) in queue.
Mar 30 14:03:01 Rechner-Joshua nullmailer[5416]: smtp: Failed: Connect failed
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Sending failed:  Host not found
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery: protocol: smtp host: mail file: 1360691363.3939
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery, 9 message(s) in queue.
Mar 30 14:03:01 Rechner-Joshua nullmailer[5417]: smtp: Failed: Connect failed
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Sending failed:  Host not found
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery: protocol: smtp host: mail file: 1358077331.3807
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery, 9 message(s) in queue.
Mar 30 14:03:01 Rechner-Joshua nullmailer[5418]: smtp: Failed: Connect failed
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Sending failed:  Host not found
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery: protocol: smtp host: mail file: 1360929945.3502
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery, 9 message(s) in queue.
Mar 30 14:03:01 Rechner-Joshua nullmailer[5419]: smtp: Failed: Connect failed
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Sending failed:  Host not found
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery: protocol: smtp host: mail file: 1360853400.3571
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Starting delivery, 9 message(s) in queue.
Mar 30 14:03:01 Rechner-Joshua nullmailer[5420]: smtp: Failed: Connect failed
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Sending failed:  Host not found
Mar 30 14:03:01 Rechner-Joshua nullmailer[1378]: Delivery complete, 9 message(s) remain.

Everybody makes mistakes, me too :)

erni-berni

Hallo,
ist das die Meldung aus dem syslog beim Einstecken des USBasp Programmers in die USB Schnittstelle?
Da taucht der nämlich gar nicht auf. Ich würde so etwas ähnliches erwarten
Code: [Select]

.... usb 5-1: new low speed USB device using uhci_hcd and address 3

Hast du die Möglichkeit das Teil mal in einen Windows Rechner einzustecken, der müsste nämlich sofort ein neues USB Device erkennen?
Gruß
Reinhard

mkl0815

Evtl. auch mal über den Befehl "dmesg" in der Konsole schauen. Einige Distributionen schreiben nicht alle Infos nach syslog. dmesg ist das etwas näher am Kernel dran.

legotechnicus

Also hier ist die dmesg Meldung aus dem Terminal als Textdatei, weil sie zu groß ist für den Post. Das letzte Gerät sieht mir nach dem Programmer aus oder ?
Everybody makes mistakes, me too :)

mkl0815

Die letzten Zeilen hätten gereicht :-) DU hast quasi den gesamten Lebenslauf Deines Rechners seit dem letzten Booten gepostet  :D
Aber, ja der letzte Eintrag scheint der Programmer zu sein.

Wichtig ist die Zeile:
Quote
[ 8594.248073] usb 7-2: New USB device found, idVendor=16c0, idProduct=05dc

Denn hier stehen VendorID und ProductID und die sollten zum avrdude passen. Wie sieht denn der Eintrag in der programmer.txt und der board.txt aus?
Kannst Du avrdude direkt aufrufen?
Mario.

legotechnicus

Ich poste beide gleich,aber in der Programmers.txt ist der oben genannte USB asp Eintrag vorhanden.
Everybody makes mistakes, me too :)

Go Up