Go Down

Topic: Arduino WiFi shield with HDG204 chip. (Read 2232 times) previous topic - next topic

mcrane

Mar 24, 2013, 01:50 pm Last Edit: Mar 24, 2013, 01:59 pm by mcrane Reason: 1
Setup:
1. Arduino Mega2560
2. Arduino WiFi Shield with HDG204 chip.

Issue:
Web client displays "Connection Lost" when performing an HTML GET using an Arduino WiFi shield with an HDG204 chip.

We have purchased 2 Arduino WiFi shields that have the HDG204 chip instead of the HDG104 chip on board.  According to Arduino, via the supplier, there should be no difference between the HDG104 and the HDG204.  However, we are not able to run the WiFiWebServer example from http://arduino.cc/en/Tutorial/WiFiWebServer using the WiFi shields with the HDG204 chip.  It works perfect with the shields that have the HDG104.

The only thing we found on Google was the HDG204 chip is 1mm bigger than the HDG104.

I was wondering if anyone else has seen this or knows what we are doing wrong?  

pow213

I'm having a similar issue with the HDG204 chip on my new WiFi Shield. In a project I'm working on with a friend, the HDG104 Shield works fine, but when I connect the HDG204 Shield in its place I can't connect to a local server that my friend wrote. Again, there is no issue with the HDG104 Shield, only with the HDG204 Shield. If anyone has any idea why this is happening I'd really appreciate it, otherwise we've got to scrounge for an older shield with the HDG104 chip. Thanks!

mcrane

#2
Apr 03, 2013, 01:56 pm Last Edit: Apr 03, 2013, 02:02 pm by mcrane Reason: 1
I sent an email to Arduino Support, too, but never got a response.  So, I've been looking at the Raspberry Pi with a WiFi dongle.  It's not as clean a solution as plugging a shield onto the top of the Mega, but it's about half the cost of the Arduino WiFi shield and probably will make a better web server.

Are you using a Mega or Uno?  We were wondering if it is an issue with the Mega only, since no one else seems to be seeing this issue.

pow213

We're using a Mega. I'm thinking it's too new for most people to have experienced it yet, or to realize what the problem is.

srrichie

I don't know if it's related, but I'm using a Arduino UNO Rev 3, same wifi shield of you, and I don't know if it's working properly.

It connects to the network, but printing out the network info always gives me:

Code: [Select]
Attempting to connect to WPA SSID: phwifi
You're connected to the networkSSID: phwifi
BSSID: 0:0:0:0:0:0
signal strength (RSSI):0
Encryption Type:0

IP Address: 192.168.2.6



The ip changes, but all the other infos are always zero.

Alexboy

I`am using UNO R2 + Arduino wifi shield, HDG104 chip.  When i`am trying to find available networks serial writes down following:
Initializing Wifi...
MAC: DE:AD:BE:EF:FE:ED
Scanning available networks...
** Scan Networks **
number of available networks:0
Encryption Type: 0

zildjian

Hi folks,

I know this topic is old but I want it up.

I bought 5 WifiShield R3 and 5 arduino uno Rev3.

I got 3 HDG104 chipset WifiShield and 2 HDG 204. I agree with you, with HDG104 it works fine after a firmware upgrade (http://arduino.cc/en/Hacking/WiFiShieldFirmwareUpgrading) (note that the procedure is not as clean as it seems...)

For the two HDG204 equiped shield, I've the same issue connecting to the simple web server wifi.

One of this card now work fine just repeating many times firmware update (first updating shield and after that updating shield and HD wifi module)


For the second one, it don't work at all and now, the card does not response "Wifi shield not present" on serial monitor.

I wonder if anyone fix that or if arduino team could check that?

Regards


Alexboy

Hi zildjian,

My issue has resolved Arduino shop techni?ian. I`ve bring arduinos to him and he states that there is bug on Arduino Wifi Shield.
I have bad chip soldering. Try to push  it harder/softer meanwhile connecting proceed. Following solves my issue and i ordered new one WIFI Shield.
If soldering is good and issue is not in factory bu, response, i will try to help you.

B83s

Hi all WifiShield Desperates !

I spent several hours trying to run wifi exemples on my official wifi shield (HDG204, I don't know if it changes something), Uno Rev 3 and 1.05 software ... the wifi connection works but wifi Server and Client never.

I've read a lot of things (flashing the wifi shield ...that I don't want for an out-of-the-box new shield)  and somewhere, I read that it is recommended to downgrade to Arduino 1.03 ... and it works immediately (for me !) !

If this can help other WifiShield Desperates

mrmills129


I read that it is recommended to downgrade to Arduino 1.03 ... and it works immediately (for me !) !

Thank you B83s!!

This also worked for me. I was running IDE 1.0.5 and I was able to get it to connect to a network, but it wasn't working as a server. Tried upgraded firmware on it but it was for the HDG104 chip and didn't work. I downgraded to IDE 1.0.3 and it worked beautifully.

Kinda sad that this is still an issue since it's been happening for over a year and the shield cost $70+.

SurferTim

You can downgrade to IDE v1.0.3 or upgrade the wifi shield firmware.

Go Up