Pages: [1]   Go Down
Author Topic: Arduino fallado  (Read 693 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola a todos, soy nuevo en esto, mi nombre es Nicolas, tengo 26 años, soy de argentina y estudiante de ingenieria en sistemas..
me compre 2 arduinos para experimentar un poco. ambos los compre en dealextreme. uno de ellos en un pack para principiantes y el otro en forma individual.
ambos arduinos me llegaron con algunos pines doblados, pero con mucho cuidado se los acomode.
el problema ahora es cuando quiero pasarle la programacion a uno de los arduinos, esta nunca termina de concretarse y el arduino queda siempre con la programacion por defaul (blink del pin 13 con 1 seg prendido y 1 seg apagado.)
sin embargo el otro arduino anda perfecto.
queria saber si hay alguna otra forma de probar / detectar / solucionar el problema, ya que no es muy util un arduino que solo sirva para prender y apagar un led smiley-razz

desde ya muchisimas gracias!


* 2013-03-23 14.38.28.jpg (526.02 KB, 2592x1936 - viewed 20 times.)

* 2013-03-23 14.38.39.jpg (462.97 KB, 2592x1936 - viewed 14 times.)
Logged

Offline Offline
Sr. Member
****
Karma: 8
Posts: 252
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola. Soy nuevo en esto de Arduino también, no se cuál podría ser el problema.

Probá en diferentes USB de tu PC, asegurate de estar mandando el código en el COM correcto. Eso lo que se me ocurre como primer paso. Fijate que el Chip esté en la posición correcta (por las dudas)

Luego lo que yo haría y viendo que tenes 2 Arduino UNO, sería pasar el Chip de uno al otro, para descartar al menos si el problema está o no en el chip.

Después la verdad que no se por dónde se podría seguir.

PD: ¿Cuando lo conectas el PC te lo detecta bien?

PD2: ¿El chip que se ve en la foto parece golpeado no? Esa raya que tiene al medio...

Finalmente, si no sabes que hacer, quizás podrías probar mandando nuevamente el Bootloader al Arduino que no funciona, no se bien como se hace, pero si vino algo fallado, podría ser lo que está causando problemas.

http://arduino.cc/es/Guide/Troubleshooting#toc1
Logged

My 3x3x3 Led Cube

[url=http://arduino.cc/forum/index.php/topic,1642

Argentina
Offline Offline
Newbie
*
Karma: 1
Posts: 19
Arduino Fan
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola. Yo compré exactamente el mismo Arduino en Dealextreme y la verdad que funciona perfectamente.
Revisá bien que en la placa no haya ninguna pista levantada. También podes probar intercambiando los micros para descartar la posibilidad de que sea un problema del uC Atmel.

Lo mas probable es que sea algo de drivers o de selección de los COM. Revisá eso.
Desinstalá, reinstalá drivers y probá cambiando de puerto USB.
Asegurate que esté seleccionado ARDUINO UNO en el IDE de Arduino (Menú Herramientas - Tarjeta - Arduino UNO)

PD: También soy de Argentina, tengo 26 años, y estudio sistemas smiley-razz
Logged

COM22
Offline Offline
God Member
*****
Karma: 6
Posts: 702
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Puede que el fallo sea del firmware del chip que hace la conversión de USB a serie, y diría que es un ATmega8u2.

Cuando subes un programa se queda encendido el LED del pin 13?
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Antes que nada muchisimas gracias a todos por su respuesta!
por ahora lo que hice fue esto: enchufe un arduino q anda y le pase programas, anda OK. (esta seteado en Arduino Uno y el COM correcto)
desenchufo ese arduino y echufo el otro que vino precargado con el programa BLINK (prende el pin 13 cada 1 segundo).
cuando intento pasarle un programa al arduino, se queda en cargando..... y nunca le pasa el programa (sigue con el BLINK de 1 segundo).
lo que no he probado aun es eso de intercambiarle los chips, es lo que voy a probar ahora...
les cuento en un rato
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

al parecer encontre la solucion...
al instalar el primer arduino, instale los drivers y lo reconocio como com 8.
pero el segundo arduino, no me tomaba los mismos drivers ya que estaba en el com13, asi que tuve que instalar los drivers nuevamente para el segundo arduino y listo
eso me pasa por asumir que con una instalacion de drivers bastaba para todos los arduinos.
Muchas gracias por su ayuda!
Logged

Offline Offline
Sr. Member
****
Karma: 8
Posts: 252
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Gracias por comentar cuál fué tu solución, así si nos llega a pasar algo similar, ya sabemos como podríamos solucionarlo.

Logged

My 3x3x3 Led Cube

[url=http://arduino.cc/forum/index.php/topic,1642

Pages: [1]   Go Up
Jump to: