Pages: [1]   Go Down
Author Topic: bluesmirf gold  (Read 2541 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 79
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,

Ik wil met mijn telefoon (android) communiceren met bluetooth.

Hiervoor heb ik een arduino uno board en een bluesmirf gold bord.

Ik heb alleen geen flauw idee hoe ik hier aan moet beginnen.

Heeft er iemand een voorbeeld code voor de arduino?
Verder las ik dat ding 3,3V nodig heeft en bij 5V overbelast wordt? is dit waar?

Alvast bedankt voor jullie reacties.
Logged

Netherlands
Offline Offline
Jr. Member
**
Karma: 0
Posts: 77
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hier staat genoeg om je in ieder geval op weg te helpen...

http://wiring.org.co/learning/tutorials/bluetooth/
Logged

Watch my stealth-bot @ let's make robots

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Of:

http://www.amarino-toolkit.net/index.php/getting-started.html

Je arduino heeft een 3.3v output die je kan gebruiken als voeding voor je bluetooth ding. smiley
Logged

Belgium
Offline Offline
Full Member
***
Karma: 6
Posts: 135
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

 smiley-razz  crosspost naar zelfde vraag & antwoord in arduinoforum.nl : http://arduinoforum.nl/viewtopic.php?f=8&t=337#p1707
Logged

Gear: Arduino- Uno,Due,Ethernet,  OLS, Buspirate, J-Link, TDS1002, Rigol DG1022

Offline Offline
Jr. Member
**
Karma: 0
Posts: 79
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

om een oud topic weer nieuw leven in te blazen.

de tutorial van Stealth krijg ik niet werkend, ik weet niet wat ik met het 2e gedeelte van de code moet doen. Moet deze geplatst worden in een andere programmeer omgeving?

ik ben nu aan het sukkelen met de armarino.

In ieder geval dank voor de reacties.
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 79
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ook krijg ik het met amarino niet werkend.

Ik heb geprobeerd de test te draaien.

ik kreeg wel verbinding (groene lampje brand) maar de led gaat niet knipperen.

iemand een idee waar te beginnen met foutzoeken?
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 79
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

kan iemand mij helpen?

Ik heb nu verschillende tutorials gevolgd, maar ik krijg het gewoon niet werkend

de armarino
Arduino Commander
de gewone tutorial van arduino zelf

Ik heb al wel succesvol de baudrate aangepast naar 115200.

Heeft iemand een tip?

Logged

The Netherlands
Offline Offline
Edison Member
*
Karma: 47
Posts: 1544
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ik kan je niet echt helpen, maar je hebt toch wel gemerkt dat de code in de link van Stealth0113 geen Arduino code is ?
Zo te zien (ik heb niet de hele pagina gelezen, alleen de code ff gauw bekeken) is het wel C maar dan bedoeld om te werken op je windows pc.
Je moet dan dus de code aanpassen zodat ie voor je Arduino geschikt word.

Het is natuurlijk wat  lastig om support te krijgen als er niemand op het NL forum actief is die hier al eens mee aan de gang is geweest.
Dat geldt sowieso voor mij, ik kan je niets inhoudelijks vertellen om je direct aan de gang te krijgen.

Wanneer je experimenten al wel een code hebben opgeleverd (werkend of niet), dan is het wel raadzaam dat je dat hier neerzet.
Dan kan er vast wel iemand naar kijken om te zien of er niet iets voor de hand liggends is.
En heb je een foto of schets van je verbindingen ?
Logged

Have a look at "blink without delay".
Did you connect the grounds ?
Je kunt hier ook in het Nederlands terecht: http://arduino.cc/forum/index.php/board,77.0.html

Offline Offline
Jr. Member
**
Karma: 0
Posts: 79
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo Hartelijk dank voor je reactie.

Ik kwam er al achter dat de eerste code niet arduino geschikt is. (ook omdat hij niet wilde uploaden)

Wat ik nu oa gedaan heb is geprobeerd arduino commander werkend te krijgen.

de voorlopige aansluitingen die ik heb zijn die van de BT-modem.
Hier heb de VCC aan de 5v, de GNd aan de GND
De TX aan de RXBT en de RX aan de TXBT
De RTS-0 en de CTS-I heb ik ook doorverbonden.

via de tutorial van onderstaande link heb ik de baudrate aangepast naar 115200
http://www.buildcircuit.com/how-to-change-baud-rate-of-bluetooth-modem-bluesmirf-gold-using-arduino-terminal/

en heb ik dit geprobeerd
http://arduinocommander.blogspot.nl/p/blog-page_27.html

In de up te loaden code heb ik wel de baudrate veranderd naar 115200
Ik krijg wel verbinding, maar het werkt niet.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 37
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Heb je al eens op http://playground.arduino.cc//Main/InterfacingWithHardware#Communication (Bluetooth sectie)  of http://playground.arduino.cc//Main/InterfacingWithHardware#viamobilephone gekeken ?
Logged

The Netherlands
Offline Offline
Edison Member
*
Karma: 47
Posts: 1544
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote from: Nald
Ik krijg wel verbinding, maar het werkt niet.

Met andere woorden: er is wel een (BT) radio verbinding, maar geen seriële verbinding met je Arduino.

Dan zou ik zeggen: sluit eens een LEDje aan op de TX uitgang van je BT module (natuurlijk via een weerstandje).
Die zendt dus naar je Arduino wat je aan de BT kant ontvangt als het goed is.
De verbinding met je Arduino RX en TX pins laat je dan  nog even achterwege.
Stuur dan eens wat data naar je BT module en kijk of je LEDje oplicht.
A|s je een scope hebt kun je die ook in plaats van het LEDje gebruiken en zien dat er data over de lijn gaat.
Voor de zekerheid kun je ook de RX ingang van je module voorzien van een LEDje (van een andere kleur) met weerstandje, maar die zou dan dus nooit aan moeten gaan.

Houd er wel rekening mee dat je de data vrij snel verzendt en dus dat het LEDje ook maar heel kort zal oplichten.
Daarom kun je beter een bergje data sturen, dan kun je het oplichten van het LEDje beter registreren.

Op deze manier ga je testen of er überhaupt wel data aankomt op je Arduino.
Verder moet je er wel rekening mee houden dat je dus je seriële verbinding gebruikt en je dus niet de mogelijkheid hebt om die te gebruiken om me te kijken via terminal.
Als je dat wel wil, moet je de data tussen BT en Arduino via een andere niet hardwarematige serial doen (softwareserial dus).
Logged

Have a look at "blink without delay".
Did you connect the grounds ?
Je kunt hier ook in het Nederlands terecht: http://arduino.cc/forum/index.php/board,77.0.html

Offline Offline
Jr. Member
**
Karma: 0
Posts: 79
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ik heb via een app verbind gemaakt met de bluetooth dongle

verder geen software geupload naar de arduino

De TX en de RX van de bluetooth heb ik allebij op een verschillende LEd aangesloten en maken dus geen verbinding met de arduino.

Of ik nu wel of geen verbinding heb met de bluetooth dongle blijft de LED van de TX constant branden. De RX blijft ten alle tijden uit.

Als ik je goed begrijpt en ik wil uitlezen wat ik ontvang via de BT terminal, dan moet ik de TX-BT aan bijvoorbeeld de digitale pin 7 hangen en die via een Serial.read-print uitlezen?
Logged

The Netherlands
Offline Offline
Edison Member
*
Karma: 47
Posts: 1544
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Als je via de terminal van de IDE wil uitlezen wat je BT module aan je Arduino zendt, dan kun je die module dus niet aan de hardware serial hebben.
Inderdaad zou je dan dus bijvoorbeeld pin 7 en softwareserial kunnen gebruiken.
Je kunt ook een display aansluiten en daar de data voorbij laten komen, net wat het best in jouw straatje past.

Het kan zijn (ik weet het eigenlijk niet uit het hoofd) dat de data die verzonden word betekent dat de lijn naar nul getrokken word.
Dat kan dan verklaren waarom het LEDje blijft branden.
Als je want meer data verstuurt, word dan het LEDje wat minder helder ?
Logged

Have a look at "blink without delay".
Did you connect the grounds ?
Je kunt hier ook in het Nederlands terecht: http://arduino.cc/forum/index.php/board,77.0.html

Offline Offline
Jr. Member
**
Karma: 0
Posts: 79
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ik heb niet het idee dat de led minder fel gaat branden.

Maar we hebben het over data versturen, hoe weet ik dat ik uberhaupt data verstuur als ik verbinding heb via de android telefoon.

Maakt het dan niet uit hoe de baudrate staat.

Ik gebruik nu het amaruino test gedeelte die stuurt om de 5 sec een willekeurig getal.
Logged

Pages: [1]   Go Up
Jump to: