Pages: [1]   Go Down
Author Topic: How to connect a FTDI cable with GBoard?  (Read 1312 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Full Member
***
Karma: 1
Posts: 158
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I bought this Arduino board with embedded GSM/GPRS module, called "Gboard": http://imall.iteadstudio.com/im120411004.html

This board has no USB connector, but is programmable via FTDI. I found a "Com Socket" on the board, see http://imall.iteadstudio.com/media/wysiwyg/Products/IM120411004_GBoard/IM120411004_GBoard.jpg but now I do not know how to connect the cable with the board.

I have a "normal" FTDI cable from Adafruit https://www.adafruit.com/products/70 datasheet: http://www.ftdichip.com/Support/Documents/DataSheets/Cables/DS_TTL-232R_CABLES.pdf

On the FTDI cable I have this pins:

black  - GND
brown  - CTS#
red    - VCC
orange - TXD
yellow - RXD
grenn  - RTS#


But on the Gboard I have different pins, see http://imall.iteadstudio.com/media/catalog/product/cache/1/image/9df78eab33525d08d6e5fb8d27136e95/i/m/im120411004_2.jpg there are

NC
GND
VDD33
Rx
Tx
GND
DTR


Is the  "Com Socket" on the Board the right place to program the GBoard or do I have to search for an other connector? When this is right: How do I have to connect the Com Socket on the board with the pins on the FTDI cable?

Iteadstudio--the manufacturer of the GBoard--recommend this part "Foca: A Tiny USB to UART Tool" for programming: http://imall.iteadstudio.com/im120525005.html but this is also "only" a UART Tool like the FTDI cable or isn't this right?
« Last Edit: April 01, 2013, 11:57:42 am by Clemens » Logged

Austin, TX
Offline Offline
God Member
*****
Karma: 12
Posts: 524
carpe diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset


The Comm Socket is the correct place to connect your FTDI cable.
The "Foca: A Tiny USB to UART Tool" serves the same purpose as your FTDI cable.

You will need to put a header on the Gboard and then rearrange the pins on the FTDI cable to match the following pinout:

Gboard:         FTDI:

NC
GND             black   - GND
VDD33           red     - VCC
Rx              orange  - TXD
Tx              yellow  - RXD
GND             NC
DTR             green   - RTS#
Logged

Offline Offline
Full Member
***
Karma: 1
Posts: 158
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks a lot! This works now!

I connected the FTDI cable this way (more or less same as above :-)
 
GBoard  FTDI
------  ----
NC            (not connected)
GND     GND
        CTS#  (not connected)
VDD33   VCC
Rx      TXD
Tx      RXD
GND           (not connected, one pin for GND is sufficient)
DTR     RTS#



It seems to be important to set the UART via jumper correct:
http://arduino.cc/forum/index.php/topic,146708.0.html

The only problem I see atm is: When I plug in the USB cable, then click upload, press reset on the board all works fine and the sketch is uploaded. But after a second trial uploading an other or modified sketch the IDE reports "Serial COM already in use". After unplugging the USB--waiting a moment--insert the plug again--it works fine. But I have to do unplugging. Any idea how to avoid this?
Logged

Austin, TX
Offline Offline
God Member
*****
Karma: 12
Posts: 524
carpe diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Do you have the Serial Monitor open or any other application connected to that serial port?
You need to close the Serial Monitor or disconnect from that serial port before you upload again.

Otherwise, avrdude from the previous upload may not have terminated properly and still have that port open.

Open Task Manager to see if you have any avrdude processes still hanging around after you finish the upload.
Logged

Offline Offline
Full Member
***
Karma: 1
Posts: 158
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks Louis, seems that it has really something to do with the serial monitor. Sketches without using the serial monitor are uploaded without any problem. Also auto reset is done and I do not have to press the reset button. But with use of the serial monitor something is problematic and I have to unplug and replug USB connection for uploading a new sketch. I tried to reinstall the FTDI driver but still the same (Win7 / Arduino IDE 1.0.4).
Logged

Kathu, South Africa
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Greetings

I have the same experience; Trying to interface a Gboard 1.0 to an UartSBee V4. My pinouts are as follows:

Gboard:
    NC
    GND
    VDD33
    Rx
    Tx
    GND
    DTR

UartSBee:
    DTR
    Rx
    Tx
    VCC
    CTS
    GND

I understand the connection of GND, Rx & Tx crossed over. But what to do with CTS, DTR and VCC and VDD33?
If I remember this correctly, DTR stands for DataTerminalReady and CTS for ClearToSend. Therefore, if I assume the GBoard to be the "Data Terminal", then its DTR must be connected to the UartSBee's CTS, with activity on the DTR pin telling the UartSBee that it is OK (clear) to send data. Verification on this would be appreciated.

Lastly, must VCC and VDD33 be connected?
Logged

Offline Offline
Full Member
***
Karma: 1
Posts: 158
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes,

VDD33 - VCC
DTR - RTS

and CTS is not connected.


Logged

Kathu, South Africa
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi Thanks for the reply. Two down, one to go.  smiley

There is no RTS on either of the boards... ? smiley-confuse
Logged

Offline Offline
Full Member
***
Karma: 1
Posts: 158
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Sorry, RTS is on the FTDI cable only. Connect DTR - DTR on both boards, and CTS is not connected.
Logged

Kathu, South Africa
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thank you, Clemens. I am going to try this. Will give feedback
Logged

Pages: [1]   Go Up
Jump to: