Go Down

Topic: Some help with DS1307 (Read 3525 times) previous topic - next topic

peres

This is an old post but..
Have you found a solution to this?

I have the same problem. (Tiny RTC module from Ebay)
This happens every time arduino power is lost.
I have tested this with the I2C scanner.

To get connection to the RTC again, I just have to disconnect and reconnect the 5v to the RTC.
Then RTC communicates on the I2C bus.
By the way, adding 4.7K pullups did not help either.

Do somebody else have the same issue?

Per Emil

NickPyner

Are you alluding to this?

Quote
but when I open the serial print all I see is:
165/165/165 45:165:165


I believe it is caused by inadequate power.

I had this just a couple of days ago, and all I had done was change the motherboard in the desktop. Getting power from a 9v wall art solved the problem. This is not as inspired as it might sound, there had been signals before about sailing too close to the edge, and I was fortunate in that both my code and proto shield had been proven 100% kosher. An LCD display, or firing up the Ethernet or more likely to be the villain.  I see no evidence of that here, but it could be just a bit of slack arsed soldering, which would lead to the same result.

If what I say sounds right but you have no external PS, you might be able to fix it by running off a USB at the back of your box. I was using a non-powered hub in the front.

Voodoo65

When I was having this same problem I eventually figured out it was because that code only applies to the Uno board. The SCL and SDA lines are different depending on the board.
Refer here http://arduino.cc/en/Reference/Wire for proper connections for the various boards.

Go Up