Pages: [1]   Go Down
Author Topic: Avrdude not in sync  (Read 477 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 9
"Oui, je suis un criminel. Mon crime est celui de la curiosité."
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour.
J'ai une arduino uno r3 avec laquelle j'essayais d'allumer une lampe en 250v grace à un relais 230V. Je ne sais pas trop ce qui c'est passé j'ai pourtant bien branché les fils de courants sur "COM" et "VCC" du relais, et les +, - et signal de l'arduino sur la bonne prise du relais, mais quand je lance le programme la lampe s'allume, puis quand je lui demande de l'éteindre, le courant saute au disjoncteur de la maison :/.

Du coup je le rallume en débranchant soigneusement la lampe et la carte arduino. Maintenant que je la branche sur mon ordi : le pilote est bien reconnu, dans le gestionnaire des prériphériques j'ai bien Arduino Uno R3 en COM7.
J'essaye alors de lancer un programme et j'ai le droit à :
avrdude: stk500_getsync(): not in sync: resp=0x00

Du coup j'ai peur d'avoir endommagé la carte ... Que dois-je faire pour la réparer (si c'est possible) ?
Logged

France
Offline Offline
Faraday Member
**
Karma: 55
Posts: 5347
Arduino Hacker
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour,

Si les plombs ont sauté c'est que ton câblage n'était pas si bien fait que ça finalement smiley-wink
Et si tu n'avais pas prévu d'optocoupleur pour isoler ta carte du 220v c'est sûr qu'elle a pas du aimer le truc.

Même question qu'ici :
http://arduino.cc/forum/index.php/topic,157902.msg1182905.html#msg1182905
Logged

Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

Offline Offline
Newbie
*
Karma: 0
Posts: 9
"Oui, je suis un criminel. Mon crime est celui de la curiosité."
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Mince... je n'ai pas de deuxième arduino, je vais voir pour me procurer de quoi réparer ou carrément en acheter une autre.

La prochaine fois je me renseignerais mieux avant de jouer avec le 230v ^^' : j'avais utilisé ca : http://www.robotshop.com/productinfo.aspx?pc=RB-See-83&lang=fr-CA et j'ai branché les fils sur le COM et VCC comme s'il s'agissait d'un interrupteur comme j'avais vu sur internet.


Enfin bon, merci de la réponse rapide.
Logged

France
Offline Offline
Faraday Member
**
Karma: 55
Posts: 5347
Arduino Hacker
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Mince... je n'ai pas de deuxième arduino, je vais voir pour me procurer de quoi réparer ou carrément en acheter une autre.
Un programmeur d'avr c'est même pas 10$ sur ebay smiley-wink
Sinon si tu as un port série RS232 tu peut te faire un "ponyprog" pour une programmation qui roxe du poney smiley-mr-green

La prochaine fois je me renseignerais mieux avant de jouer avec le 230v ^^' : j'avais utilisé ca : http://www.robotshop.com/productinfo.aspx?pc=RB-See-83&lang=fr-CA et j'ai branché les fils sur le COM et VCC comme s'il s'agissait d'un interrupteur comme j'avais vu sur internet.
Ho là boulette ...
C'était COM et ON/OFF pour le 220v ...
Si t'as envoyé le 220v dans le +5v (VCC) de l'arduino c'est définitivement foutu pour l'arduino ...
Tu auras pris une carte à relai avec optocoupleur 15€ au lieu de 7€ tu auras pas eu de probléme smiley-wink
(Au passage t'as du cramer le relai)

Voir le schéma en pièce jointe pour mieux comprendre.


* schematics.JPG (83.34 KB, 1706x809 - viewed 24 times.)
Logged

Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

Pages: [1]   Go Up
Jump to: