Go Down

Topic: Burning Bootloader onto Atmega 2560 (Read 14774 times) previous topic - next topic


I'm having issue trying to burn the bootloader to an Atmega2560 on a custom PCB using an UNO. The schematic for the entire PCB is attached to my post (ignore the peripherals and power supply connected to the MCU). I have test points to the necessary pins needed for ISP. I wired the Arduino UNO to the right pins on the Atmega2560 on our PCB as shown in the Arduino tutorial with a 10 nf capacitor wired between reset and gnd on the UNO.

Next, I open the Arduino IDE and open the Arduino ISP code under the examples. I plug in the UNO and upload this code it with no issue. However, I am receiving error messages each time I try to burn the bootloader.

The first message I got said "expected signature for Atmega2560 is 1e 98 01. Select -f to override." I go to serial monitor and type -f but nothing happens. I looked up a few forum posts and people say you need to configure your Atmel chip under the "avrdude.config" folder that is in your Arduino folder under avr/etc/.... I go there and don't see it so I upload the newest version of Arduino v.1.5.2. This folder is there so I try burning the bootloader again and that's where I get the message "stk500_getsync() not in sync resp=0xff". I tried researching this message to no avail.

Any advice or ideas would be greatly appreciated.


Did you try Nick Gammons tutorial?? The tutorial is easy and awesome at the same time =).. Try the Atmega Board Programmer, a lot easier than the built in Arduino IDE solution.. Here is the link: http://www.gammon.com.au/forum/?id=11635


I tried that but after spending a whole day working on the project,we learned our chip doesn't need a bootloader. Somebody explained that it has something to do with not having a USB-to-serial conversion chip on our PCB if I remember correctly. We were led to using the AVR pocket programmer found here: https://www.sparkfun.com/products/9825 which let us easily upload the Blink sketch with no issue.

I do appreciate the help though. The Gammon tutorial does make up for a lot of the issues I was reading that dealt with uploading the Arduino bootloader.

Go Up