Pages: [1]   Go Down
Author Topic: SAM-BA operation failed on Due  (Read 3850 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 55
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi

I started getting this error on sketch upload - then tried another PC and it worked. Then tried the original PC and it worked. Now trying both, and getting the error again on both. Different cable too.

Sometimes it shows some pages loaded. Is my board dud?
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 55
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

And now a sketch uploaded...I can only think the board is faulty.
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 55
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Which makes me wonder why there isn't adequate QA. This is not acceptable.
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 55
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset


The board seemed to get further as it was connected longer ... eventually the full sketch would load (with no hardware changes => the two geniuses).

Now it does not load at all.

Is there an official Due support site?
« Last Edit: May 27, 2013, 02:01:30 pm by Coding Badly » Logged

nr Bundaberg, Australia
Offline Offline
Tesla Member
***
Karma: 126
Posts: 8490
Scattered showers my arse -- Noah, 2348BC.
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Is there an official Due support site?
This is it, although not that many people have experience with the Due yet I think.

So far it sounds like you've swapped everything except the Due, that points to a flaky board but you need another one to prove it.

______
Rob
Logged

Rob Gray aka the GRAYnomad www.robgray.com

Offline Offline
Jr. Member
**
Karma: 0
Posts: 55
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks Rob- I bought a new board today, no problems with loading. Old board - old problem.

Then I checked the old board under a magnifier - some pins were pushed together (I must have knocked the board at some stage), and there were some minute junk fragments elsewhere. Cleaned it up - now I have two working boards.

Which is not a bad thing...
Logged

nr Bundaberg, Australia
Offline Offline
Tesla Member
***
Karma: 126
Posts: 8490
Scattered showers my arse -- Noah, 2348BC.
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Good to see you got it working.

_____
Rob
Logged

Rob Gray aka the GRAYnomad www.robgray.com

Offline Offline
Newbie
*
Karma: 0
Posts: 27
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

SAM-BA operation failed -> you've connected to the native usb port,

Solution: change the usb cable from the native port to the due programming port ;-)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 16
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

SAM-BA operation failed

For future reference this also occurs when you have RX0 and TX0 connected to another device and try to upload new code.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi!

I had the same error message. It turned out that all serial ports of the Due have to be unconnected when you're programming it - after doing so the error ceased.
Logged

Logroño - Spain
Offline Offline
Sr. Member
****
Karma: 2
Posts: 270
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Hi

I started getting this error on sketch upload - then tried another PC and it worked. Then tried the original PC and it worked. Now trying both, and getting the error again on both. Different cable too.

Sometimes it shows some pages loaded. Is my board dud?

Hi,

I have 1) the same problem (some times); in addition to this, 2) the COM7 sometimes fails and, finally, 3) I am unable to change the baud rate of the communication (Serial monitor).

In the first two I DO manage by using the "switch OFF switch ON" manoeuver (not exactly the computer but disconnecting the cable, then unabling the COM7 port -or mixing these two in underminated proportions and sequence-: normally it all recovers and I keep on working).

(By the way, I've posted several times asking for help to change the baud rate -see image attached-. ¿Would anybody help me?).

In my -humble- opnion what happens is that, as Valentín Canadell stated 25 years ago, "computing is not an exact science" (or, better, he said "I thougth computing was an exact science" just after noticing it is not smiley-wink)

(Just for spanish speakers: Valentín Canadell dijo "hostias, yo pensaba que la informática era una ciencia exacta".)


* BAUD_RATE.bmp (1417.25 KB, 955x506 - viewed 46 times.)
Logged

Pages: [1]   Go Up
Jump to: