Go Down

Topic: Bootloading troubles on the 328P-PU.... (Read 2643 times) previous topic - next topic


I'm trying to bootload the atmega328P-PU, exactly as shown in here, http://arduino.cc/en/Tutorial/ArduinoISP. I have a 328P-PU on my arduino dumilanalov, to which i burnt the arduino ISP sketch, then i tried burning the bootloader to the 328P-PU in breadboard.
I keep getting this error,
avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.

I rechecked the avrdude.conf file and the device signature was still " 0x1e 0x95 0x0F", which I'm guessing is the right one for 328P-PU. I also tried disabling auto reset by placing a 10uF cap across RESET and GND, but i keep getting the same error.

Any help will be deeply appreciated.... :(


I have a sketch here that will program a bootloader without using avrdude:

Please post technical questions on the forum, not by personal message. Thanks!

More info: http://www.gammon.com.au/electronics


Jan 22, 2013, 09:15 pm Last Edit: Jan 22, 2013, 09:22 pm by LarryD Reason: 1
I don't know if this will help but I have had good luck with this: http://www.gammon.com.au/forum/?id=11635
This may be of some interest too: http://www.gammon.com.au/forum/bbshowpost.php?bbsubject_id=11637
No technical PMs.
The last thing you did is where you should start looking.


Jan 24, 2013, 04:40 pm Last Edit: Jan 24, 2013, 06:03 pm by Dr_Ugi Reason: 1
Did you disable auto-reset on that Ardu' that you are using as a programmer?  Not all boards require it, but a 10uf cap between ground and reset, or a 110R resistor between reset and +5V on the programmer may be needed to stop it resetting during the bootloader burning process.

I think the error you have is a general one and not directly related to an incorrect signature.  If AVRdude receives and actual incorrect signature, it will tell you what it was and what it was expecting.

Edit - sorry, I see you did disable reset.  If you also included a crystal and caps (you will need those unless you know your chip has fuses set for internal oscillator) then it's probably just a loose or miss-placed connection.  It's very easy to do.


Any help will be deeply appreciated.... :(

Show a photo of your setup. Tell us how the fuses are set in the target chip.
Please post technical questions on the forum, not by personal message. Thanks!

More info: http://www.gammon.com.au/electronics


Same problem here (328P-PU without bootloader, Arduino UNO)...
I did exacly what you described here (http://www.gammon.com.au/forum/bbshowpost.php?bbsubject_id=11637), but it does not work. I tried both ways, none of them works.
Is there anything I might have forgotten???
Thanks so far.


This is a common error if the 328P fuses are set to external clocking and you are not providing a crystal or resonator to XTAL1/XTAL2 pins.  Alternatively if you are using Nick Gammon's bootloader you can use the Arduino pin D9 to the 328P XTAL1 pin, to provide an 8MHz clock, just for programming.


Today it works. I can't explain it...

Go Up