Go Down

Topic: Problema con la lectura Analógica enArduino Uno de una funte de 12V(Solucionado) (Read 1 time) previous topic - next topic

esdaba

#5
Apr 04, 2013, 03:30 pm Last Edit: Apr 04, 2013, 03:47 pm by esdaba Reason: 1
Hola. Entiendo que no te aparecen valores intermedios entre 0 y 1023. Conecta un potenciómetro de 10K entre +5v de ARDUINO y masa y pon la patilla central del potenciómetro en A4 que parece que es la que estas usando .Muévelo y comprueba si aparecen o no dichos valores intermedios. Si no es así probablemente tengas averiada dicha entrada. Verifícalo haciendo la misma prueba con otras entradas analógicas. A mi me paso algo parecido con A0 y A1, (de 0 a 8 bien, de 9 a 750 no existían, de 751 a 1023 bien). DESCONECTA SIEMPRE ARDUINO ANTES DE MANIPULAR CONEXIONES CONECTADAS A TENSION, AUNQUE SEAN INFERIORES A 5 V. El divisor que planteas parece correcto para 12 v. pero dices que utilizas una fuente variable entre 2 y 30 v. En algún momento has superado los 12v a la entrada del divisor de tensión ? Calcula siempre los divisores de tensión para que den 5v contando siempre CON LA MAXIMA TENSION QUE PODRIA RECIBIR la entrada de dicho divisor, y luego la adaptas matemáticamente mediante el software.
Saludos.

Sergegsx

has unido el negativo de la fuente con el negativo del arduino?
Foto del montaje?
* Si preguntas, pon el código de tu programa, hace mucho mas fácil ayudarte. Y me ahorro un mensaje pidiendo que lo hagas.
* Si consigues solucionar tu problema, dedica unos minutos a explicar en tu post como lo conseguiste para beneficio de todos.
* Cambia el 'Subject' de tu hilo y añade 'SOLUCIONADO' cuando hayas llegado a una solución al problema que planteaste.
* Utiliza un 'Subject' para tu hilo que explique de que va el hilo.
Si estas empezando:
* Comienza a usar Arduino
* Guías de iniciación a Arduino
* Ejemplos
* Referencia del Lenguaje
* Conceptos básicos
Guia de usuario de arduino
Tutoriales en Ingles
Si necesitas que alguien te escriba el código: http://www.freelancer.com/  o esta  http://www.guru.com/

iceray

Respondiendo a Esdaba, sí e realizado el proceso con el potenciómetro conectado a los 5v de arduino y funcionan todas las entradas analógicas bien, el tema de unir  el negativo de la fuente con la de arduino no lo tengo tan claro, yo tengo el arduino uno y no se en que pátillas deberia meter el negativo. saludos.

American2020


Respondiendo a Esdaba, sí e realizado el proceso con el potenciómetro conectado a los 5v de arduino y funcionan todas las entradas analógicas bien, el tema de unir  el negativo de la fuente con la de arduino no lo tengo tan claro, yo tengo el arduino uno y no se en que pátillas deberia meter el negativo. saludos.


Si estás probando las cosas en un protoboard, conecta un cable de tu negativo de la fuente hacia el canal negativo del protoboard y al mismo tiempo, uno del GND del Arduino, al mismo carril.

Sino simplemente un cable desde tu negativo en la fuente hasta GND en el arduino, o desde el mismo potenciometro, como te quede más cómodo.
My 3x3x3 Led Cube

[url=http://arduino.cc/forum/index.php/topic,1642

iceray

Vale finalemente ya se lo que me pasaba. Lo unico que tenía que hacer es como a dicho american2020, es meter un cable desde el negativo de la fuente de alimentación hasta el GND de arduino, en el arduino UNO, es el pin que está justo al lado de Aref.

Así ya no se vuelve loco y siempre tiene una lectura correcta.

Gracias a todos.

Go Up