Go Down

Topic: Port change from 80 to something else (Read 3194 times) previous topic - next topic

SurferTim

Quote
So you mean these ports would work in place of port 80 ?

Yes. Some ISPs block port 80 requests to residential ip addresses. Mine does. To get around that block, one of those ips will normally work. Insure you allow that port through your firewall.

NI$HANT

I used port 8080 still the browser can;t link to it
"Real Men can Accomplish  Anything"

- skype : nishants5  

ਫ਼ਤੇਹ ਕਰੁਂ!

NI$HANT

#17
Apr 05, 2013, 03:46 pm Last Edit: Apr 05, 2013, 03:48 pm by NI$HANT Reason: 1
internal network however works fine!

ANd! I just disabled by routers firewall
"Real Men can Accomplish  Anything"

- skype : nishants5  

ਫ਼ਤੇਹ ਕਰੁਂ!

SurferTim

..and you port forwarded that port to your private localnet ip? If it still doesn't work, it may be your DSL router doing the block.

NI$HANT

Quote
..and you port forwarded that port to your private localnet ip? If it still doesn't work, it may be your DSL router doing the block.


But that what could be possible issue here? Can you outline which elements to check, I tried disabling the Firewall and restarting the router to no avail!

Should I provide you with the screenshot of my routers option/functions it supports so you may try to underline some options?
"Real Men can Accomplish  Anything"

- skype : nishants5  

ਫ਼ਤੇਹ ਕਰੁਂ!

zoomkat

Quote
internal network however works fine!


if you are trying to reach your arduino from outside your dlink router, you will need to use your wan ip address (or a service like no-ip.com), and have the dlink port forward the outside request to the lan ip address of your arduino.
Google forum search: Use Google Advanced Search and use Http://forum.arduino.cc/index in the "site or domain:" box.

NI$HANT

Quote
you will need to use your wan ip address


I know this already and im doing it/trying it but IM not able to access using the WAN IP, however at the same time the internal IP communication works smooth
"Real Men can Accomplish  Anything"

- skype : nishants5  

ਫ਼ਤੇਹ ਕਰੁਂ!

zoomkat

Have you posted your code for evaluation?
Google forum search: Use Google Advanced Search and use Http://forum.arduino.cc/index in the "site or domain:" box.

zoomkat

What are your setting on the below page?

http://support.dlink.com/emulators/di524_revc/adv_virtual.html
Google forum search: Use Google Advanced Search and use Http://forum.arduino.cc/index in the "site or domain:" box.

NI$HANT

Quote
Have you posted your code for evaluation?


My code is the very same no changes WEBSERVER ethernet example that comes with the Arduino 1.0 IDE ONLY the IP address that is 192.168.0.104 + the MAC address is changed and the Server port rest is the same.
"Real Men can Accomplish  Anything"

- skype : nishants5  

ਫ਼ਤੇਹ ਕਰੁਂ!

NI$HANT

Here are the settings done regarding PORT forwarding on my router "uC"  is arduino here:


http://www.flickr.com/photos/93413530@N06/8624125280/
"Real Men can Accomplish  Anything"

- skype : nishants5  

ਫ਼ਤੇਹ ਕਰੁਂ!

NI$HANT

Got time to check the screenshot zoomkat?
"Real Men can Accomplish  Anything"

- skype : nishants5  

ਫ਼ਤੇਹ ਕਰੁਂ!

zoomkat

#27
Apr 08, 2013, 06:04 am Last Edit: Apr 08, 2013, 06:11 am by zoomkat Reason: 1
I looked at the screen shot, and looks fairly straight forward to enter the lan ip address used by the arduino server.

edit: if you want to use a port other than 80, then set the public port start to something 81 and the public port end to something like 91. This should allow any outside request that are wanting to access ports 81 thru 91 to be forwarded to the arduino.
Google forum search: Use Google Advanced Search and use Http://forum.arduino.cc/index in the "site or domain:" box.

NI$HANT

#28
Apr 08, 2013, 08:33 am Last Edit: Apr 08, 2013, 08:42 am by NI$HANT Reason: 1
I think my DSL is screwed and I dnt know how to go about fixing that!

I used 81 start and 91 end port and used 8080 it doesn't work still

EDIT: tried an in between port namely 85 still the same
"Real Men can Accomplish  Anything"

- skype : nishants5  

ਫ਼ਤੇਹ ਕਰੁਂ!

NI$HANT

Utilised the Dynamic DNS still the same problem , can;t make out what is the possible problem?
"Real Men can Accomplish  Anything"

- skype : nishants5  

ਫ਼ਤੇਹ ਕਰੁਂ!

Go Up