Go Down

Topic: updated library UTFT version 2.1 with a CTE shield (Read 2377 times) previous topic - next topic

ageurtse

Hello,

I have altered the latest UTFT library (version 2.1) so it also run's with a CTE TFT shield.

I only altered the 16 bit mode.
you have to setup your display as follow

UTFT myGLCD(display_type,shield_type,25,26,27,28);   // Remember to change the model parameter to suit your display module!
there are 2 shield types (default_shield and CTE_shield)
the pin numbers for a CTE TFT shield are as follow (pin rs=25, wr=26, cs=27, rst=28)

in the attachement is the complete library.

It is also alone for the DUE because i don't have a Mega, but it think this could be done also easely



promacjoe

Unexpected end of archive.

Please check your file.

ageurtse

Because my uploads get corrupt i try it this way

https://mega.co.nz/#!pg5FWDxb!GXp_5TgLlTMmD5vs6o46fVbbHatGZszYGParvbVh18o

promacjoe

I was able to download the complete drivers. I tested the drivers using both the "default_shield" and  "CTE_shield" switch. I could not find any difference between the two functions, both were displayed the same, "mirrored", and is unreadable.

I am using the CTE DUE shield + CTE 7" display  "CTE70".

What is supposed to be the benefit of using one or the other switches, and how can I tell if it's working properly.

Thank you for your effort, but as of yet I cannot see any benefit to your drivers.

ageurtse

I wrote it for the CTE Shield, you have to add a driver for yout 7" tft.

that is what you have to get from the UTFT_CTE library and put it in the version i posted here.

The CTE library is version 2.0 and the last version online is 2.1

so you have to do some programming yourself.

Go Up