Pages: [1]   Go Down
Author Topic: Power up reset problem with LC7981 graphic display and u8glib  (Read 353 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 54
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Have been designing around u8glib library, (which works great by the way, Oli) and only just noticed that the display only properly initializes when it is code-dumped. That is, when I power off the arduino and lcd, on powering up, the screen goes garbled and stays that way, same for pressing arduino's reset button.  But when I make a program change, and upload it, the arduino and lcd resets properly and works perfectly.

Guessing it's a power on reset issue, possibly hardware, possibly something in the u8glib init timing.
Has anybody had any problem like this?
« Last Edit: April 09, 2013, 08:39:05 am by cornwallav8r » Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 54
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Still fighting this issue....can anyone at least tell me what the difference is, in the Arduino environment that is different with regards to program startup, as compared to powering off and on?
I mean it always works fine when i download the updated code, the display works fine.
But powering off the 5v supply which powers the lcd and Arduino, it doesn't reset properly.
Doesn't make any sense at all.  The solution lies somewhere there in the difference in how sketches are started during a program download....my best guess.  Thoughts?
Logged

Pages: [1]   Go Up
Jump to: