Pages: [1]   Go Down
Author Topic: Arduino Due - Cte Shield - Lcd 7" MD070SD  (Read 1280 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi

I'm new, so excuse me if I make stupid questions, but...

I have:
- arduino due bord
- CTE TFT LCD/SD shield for Arduino due v1.04          ( http://www.ebay.it/itm/121057447668?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649)
- 7.0" inch TFT LCD module CPLD SDRAM 800x480 arduino DUE MEGA2560 4.3 SSD1963                    (http://www.ebay.it/itm/121186426608?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649)

The LCD does not turn on.
It remains blank.

I did these steps:

1)  downloaded UTFT henning library from here http://henningkarlsen.com/electronics/library.php?id=66
2) used the sketch  UTFT_Demo_800x480.ino
3) uncomment "#define CTE_DUE_SHIELD 1" in the HW_ARM_defines.h in the \hardware\arm folder of the UTFT library
4) changed the pinout to : UTFT myGLCD(CTE70,25,26,27,28);
5) provided external power supply to arduino due (tryed with 6v dcc 1.5a and 12v dcc)

The LCD does not turn on

Any ideas?
How to know if the LCD is broken?

thank's
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi Cristian,

You are trying to initialize MyGLCD with CTE70, however CTE70 is for the SSD1963 controller, whereas your module is using a newer controller, yet unsupported by UTFT. Try to contact Henning Karsten  and request if he is going to support that module.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Done.
Thank's


Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

And I found this:


It seems the same LCD...

Maybe they use a different library
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Apparently, they are using a different library. It doesn't look like UTFT. And they mention that Mega2560 was programmed in some different environment (Bascom AVR), rather than Arduino IDE. It is probably possible to port their library (if available) to Arduino, but I am not an expert at this.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Resolved.

The UTFT works fine using this parameters    UTFT myGLCD(CPLD,25,26,27,28);

Thank's to Henning karlsen!
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

I got stuck. I am trying  to display a menu applicaion and writing some informations, icons , buttons on the display. Any help would be great .

I used this LCD and  the library example is working fine. SSD1963 diriver ic.
http://www.ebay.com/itm/5-5-0-inch-TFT-LCD-module-800x480-SSD1963-touchpad-SD-arduino-AVR-STM32-ARM-/121031842772

i am using;

1- arduino due without any shield.
2- My LCD is CPLD SDRAM based 5 " TFT  - MD050SD  link below
http://www.ebay.com/itm/5-5-0-inch-TFT-LCD-module-CPLD-SDRAM-800x480-arduino-DUE-MEGA2560-4-3-SSD1963-/121186430206

3- I am trying to use UTF library - thanks to H.Karlsen
    downloaded UTFT henning library from here http://henningkarlsen.com/electronics/library.php?id=66

But i could not get any succes about that.

First I tried that.
I tried using standart arduino shield connection for itead 3.2 TFT in the link. It is mega shield but i only use D0-D15 connection directly DUE board  without shield -> http://imall.iteadstudio.com/im120417021.html
because i can make it with SSD1963 LCD board and UTFT_Demo_800x480.ino  example. So,
 
commented  "#define CTE_DUE_SHIELD 1" and "#define EHOUSE_DUE_SHIELD 1" lines in the HW_ARM_defines.h.
UTFT myGLCD(CPLD,38,39,40,41);
UTFT myGLCD(EHOUSE50CPLD,38,39,40,41);

i used the sketch  UTFT_Demo_800x480.ino  and UTFT_CPLD_PageSwitching examples

Nothing - i can only change the LCD backlight - CPLD PWM -- between 0-16 you can change by writing "myGLCD.setBrightness(2);  "

Second i tried that CTE shield and the solution above .  i used only schematic connection of the shield. i dont have one
http://www.ebay.com/itm/TFT-SD-Shield-for-Arduino-DUE-TFT-LCD-Module-SD-Card-Adapter-2-8-3-2-inch-Mega-/121057447668

D0-D15 data bus connection is like the CTE shield schematic on the Due board - directly to the board without shield.
Then

   - i used the sketch  UTFT_Demo_800x480.ino  and UTFT_CPLD_PageSwitching examples
   - uncomment "#define CTE_DUE_SHIELD 1" in the HW_ARM_defines.h in the \hardware\arm folder of the UTFT library
   - changed the pinout to : UTFT myGLCD(CTE50,25,26,27,28);
                                           UTFT myGLCD(CPLD,25,26,27,28);
                                           UTFT myGLCD(EHOUSE50CPLD,25,26,27,28);
  - power supply to arduino due USB programming cable.

Nothing - i can only change the LCD backlight - CPLD PWM -- between 0-16 you can change by writing "myGLCD.setBrightness(2);  "
only  with UTFT myGLCD(CPLD,25,26,27,28); and UTFT myGLCD(EHOUSE50CPLD,25,26,27,28);


Finally Second i that Elechouse shield .  i used only schematic connection of the shield. i dont have one
http://www.elechouse.com/elechouse/index.php?main_page=product_info&cPath=148_211&products_id=2238

D0-D15 data bus connection is like the Elechouse shield schematic on the Due board - directly to the board without shield.
Then

the sketch  UTFT_Demo_800x480.ino
3) uncomment "#define EHOUSE_DUE_SHIELD 1" in the HW_ARM_defines.h in the \hardware\arm folder of the UTFT library
4) changed the pinout to : UTFT myGLCD(EHOUSE50CPLD,22,23,31,33);
                                           UTFT myGLCD(CPLD,22,23,31,33);

Nothing - i can only change the LCD backlight - CPLD PWM -- between 0-16 you can change by writing "myGLCD.setBrightness(2);  "
again.

I have to use this CPLD solution .

Thanks
Serkan


Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

make sure you power the arduino from the dc jack using at least 8 volts.

the display uses too much power to work via USB power only.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for reply,

I changed my power supply to 12 volt 4A but it is the same , i think it is related with the UTFT library because , i can change the LCD backlight, i mean that i can give command (registry commands) the LCD driver ic over D0-D15 and Rs,Cs,wr,Rst lines . Inside the manuel, in chinese of course , work register for the backlight control ;

CS    RS    DATA[15:0]    WR    RD    Function
0      0      0x0001          0        ×      Address points to backlight brightness register
0      1       0-16                0        ×      Backlight brightness value (default:0)

Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have the 7" CPLD with the CTE shield and it works fine with UTFT. All I do to get it working is to uncomment  "#define CTE_DUE_SHIELD 1" in HW_ARM_defines.h and declare UTFT using:
UTFT TFT(EHOUSE50CPLD, 25, 26, 27, 28);

However, it doesn't like long cables - I made a further small adapter from the CTE shield so that I could use a standard ATA cable to connect to the screen. The cable is about 200 mm long. It produces some very random results on the LCD, mainly that there is screen corruption and it keep selecting unused pages, but I also sometimes just get a blank screen. The touch screen and SD card functions still work fine though. If I use a 240 x 320 LCD (that uses a SSD1289) with the same setup then that works fine. So, cable length is an issue with the CPLD devices. Using just the CTE shield with no extension works 100% fine.

Whether or not cable/wire length is the issue, have you actually wired up *exactly* the same as the CTE shield? What have you done with RD? On the CTE shield, the RD pin is just pulled high through a resistor. On the EHouse shield, it's routed to a pin. Frankly, it's just luck that many LCDs work with UTFT and EHouse shields as UTFT doesn't handle the RD signal at, and I bet not many people do anything with the RD pin and just leave it floating. If you leave it floating and it floats to the wrong state, you just get a black screen.


While I'm here... the MD070SD seems just just emulate an SSD1963 but with more features. However, I can't seem to get the scroll commands to do anything. It's not the end of the world, but it's be nice to get this feature working. Any ideas?
Logged

Pages: [1]   Go Up
Jump to: