Go Down

Topic: Connecter une carte arduino sur une carte électronique (Read 4000 times) previous topic - next topic

68tjs

Une piste ?
Par là je veux dire que ne trouvant pas d'une manière simple où était raccordés J1-A et J1-B et que dans la phase d'alignement de l'émetteur et du récepteur le mode d'emploi indique qu'il faut mettre une résistance de 560 ohms entre J1x et le +5V j'ai pris le problème autrement et dans la nomenclature j'ai cherché des résistances de 560 ohms.
Connaissant leur numéro il est possible de retrouver le schéma qui les contient.
Ce schéma  comporte des connecteurs qu'il te faut suivre pour relier les différents schémas entre eux.
Tu as le flipper à ta disposition, je ne le ferais pas.

dandrimontp

#31
Apr 12, 2013, 09:37 pm Last Edit: Apr 12, 2013, 10:12 pm by dandrimontp Reason: 1
Alors,
Pour apporter de l'eau au moulin...

Page 160 (notée 142 dans le document), le n° J1-A et J1-B correspondent tous deux aux informations juste en dessous à gauche dans la liste des éléments selon A et B...

J'ai regardé directement dans le flipper si je pouvais savoir à quoi les câbles du receveur étaient connectés. J'ai de la chance car chaque connecteur J1 A et B de droite dans la doc (receveur) ont une couleur différente.
L'un est un cable de couleur Vert-Bleu et l'autre Blanc-Marron...
En suivant ces câbles, ils sont reliés pour :
* vert-bleu à un connecteur nommé CN5
* blanc-marron à un connecteur nommé CN7

On retrouve bien cela dans la doc en page notée 102 CN7 : WHT-BRN (pour White-Brown soit blanc-marron). Toujours dans cette page on retrouve CN5 : GRN-BLU (pour Green-Blue soit vert-bleu).
On retrouve aussi cela dans le doc page notée 104.

En fait on retrouve ces informations un peu partout mais je vois qu'en page notée 139 on parle du CN5 et CN7 et on voit apparaître la notion de 5V...mais comme il y a des résistances dérrière, je ne suis pas certain qu'il y ait que du 5V...???


68tjs

As tu trouvé où se raccorde J1-A ?
Avec un ohmmetre ce devrait être faisable.

As tu mesuré la tension en J1-A quand la sortie est l'état haut -> ce doit être du 5V à 99% mais encore faut-il en être sur.

Si c'est bien du 5V as tu identifié où se connecter sur le 5V -> attention aux alim sur lesqu'elles sont raccordés des bobines ou des electro-actioneurs c'est plein de parasites : pas bon du tout.

Il faut chercher une alim 5V du coté des cartes électroniques et si possible celle où le récepteur est raccordé -> voir question 1.
Et bien entendu noter la tension mesurée avec un chiffre après la virgule.
La valeur des tensions est importante car les circuits CMOS (les portes 74HCxxx , il y en a une ribambelle dans les schémas, le micro de la carte Arduino) ne supportent pas de voir une entrée portée à une tension supérieure à la tension d'alim + 0,5V , ou la masse -0,5V.
Tu as encore du boulot.


dandrimontp


As tu trouvé où se raccorde J1-A ?
Avec un ohmmetre ce devrait être faisable.

As tu mesuré la tension en J1-A quand la sortie est l'état haut -> ce doit être du 5V à 99% mais encore faut-il en être sur.

Si c'est bien du 5V as tu identifié où se connecter sur le 5V -> attention aux alim sur lesqu'elles sont raccordés des bobines ou des electro-actioneurs c'est plein de parasites : pas bon du tout.

Il faut chercher une alim 5V du coté des cartes électroniques et si possible celle où le récepteur est raccordé -> voir question 1.
Et bien entendu noter la tension mesurée avec un chiffre après la virgule.
La valeur des tensions est importante car les circuits CMOS (les portes 74HCxxx , il y en a une ribambelle dans les schémas, le micro de la carte Arduino) ne supportent pas de voir une entrée portée à une tension supérieure à la tension d'alim + 0,5V , ou la masse -0,5V.
Tu as encore du boulot.




Re,

Bon, j'ai acheté un voltmètre aujourd'hui et j'ai contrôlé la tension...

J'ai branché la cosse rouge sur J1-A et la noire sur J1-B.
J'ai calé mon voltmètre sur le calibre 20 en tension continue et voilà ce que j'ai eu à l'écran :
Sans la présence de la bille, valeur : -0,55
Avec la présence de la bille, valeur : -0,21

Merci de ton aide.


alienboats

Curieux !
Est tu sur de tes mesures ?
Quel appareil as tu utilisé?

dandrimontp

#36
Apr 20, 2013, 10:32 pm Last Edit: Apr 20, 2013, 10:34 pm by dandrimontp Reason: 1

Curieux !
Est tu sur de tes mesures ?
Quel appareil as tu utilisé?


J'ai utilisé l'appareil ci-dessous en photo (marque DOM modèle M830A).

Si je choisis le calibre 200, j'ai :
-sans la bille, la valeur : -00,5
-avec la bille, la valeur : -00,1

Si je choisis le calibre 2000m, j'ai :
- sans la bille, la valeur : -560
- avec la bille, la valeur :  -215


Go Up