Go Down

Topic: Burning to arduino on a breadboard...analogs (A0-A5) not recognized (Read 1 time) previous topic - next topic


Hello there, i'm following the instructions for burning my sketch onto an atmega328 on a breadboard using the 8mhz internal clock. 
I'm following these instructions:  http://arduino.cc/en/Tutorial/ArduinoToBreadboard
The sketch compiles fine on my arduino, but when I try to burn it onto an atmega328 on a breadboard it pops up with this error message:
Code: [Select]
In file included from FINAL_ARRAYS_MODIFIED_.cpp:27:
/Applications/Arduino.app/Contents/Resources/Java/hardware/arduino/cores/arduino/Arduino.h:212:26: error: pins_arduino.h: No such file or directory
FINAL_ARRAYS_MODIFIED_:30: error: 'A4' was not declared in this scope
FINAL_ARRAYS_MODIFIED_:31: error: 'A3' was not declared in this scope

I burned the bootloader onto the atmega328 already.  I have successfully used the code already, its only when trying to burn it to an external atmega328 that this issue arises.  The code will not verify due to this error message.  Any idea why this is happening? 



Hi, it seems you are missing a header file:

Code: [Select]

error: pins_arduino.h: No such file or directory

It should be in the "variants" directory under ../Java/hardware/arduino (same location as cores and boards.txt). Probably your makefile doesn't list this directory in its -I(nclude) options.


Do i need to manually add those files back in?  How should I go about correcting this?


The files are part of the standard Arduino IDE, so if they are missing from the file system you should reinstall the IDE. But if you can compile the sketch for the Arduino the files should already be there; the problem, then, is in the compiler options.

It is unclear to me how the compiler options may change depending on the board you are using. Are you compiling from the IDE, or using a command from the command line? If compiling from the IDE, which board is selected from the Tools - Board menu? I tried selecting the Duemilanove with ATmega328 and my sketch compiled fine.


Would it be less problematic to purchase an avr isp and burn IC's that way?  I just updated the software (i was using arduino 1.0).
I'm considering just wiping everything and starting over, it has been very problematic to get this working. 

I tried following the steps using an external crystal and recieved this error message output.  The IC was removed from the primary arduino board as instructed and I selected 'arduino nano w/ 328'.

Code: [Select]
Binary sketch size: 3,708 bytes (of a 30,720 byte maximum)
/Applications/Arduino-1.app/Contents/Resources/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino-1.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -carduino -P/dev/tty.usbmodemfd131 -b57600 -D -Uflash:w:/var/folders/qk/qkj6-lNJEq8p-Fz5jk0-1U+++TI/-Tmp-/build4661115695092946834.tmp/FINAL_ARRAYS_MODIFIED_simplified.cpp.hex:i

avrdude: Version 5.11, compiled on Sep  2 2011 at 18:52:52
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/Applications/Arduino-1.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/Darcyneal/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/tty.usbmodemfd131
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

avrdude done.  Thank you.


I just noticed that this is not meant to work for the Uno...oops.


Go Up