Pages: [1]   Go Down
Author Topic: avrdude: stk500_getsync(): not in sync: resp=0x00  (Read 1641 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 2
Posts: 72
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I am sharing my particular solution to the above error code.

So, I've spent nearly 5 hrs today just trying to get my LED on my Duemilanove to blink, using the Getting Started Guide here (http://arduino.cc/en/Guide/Windows), and the built-in blink program example. I kept getting stuck on Step 9, trying to "Upload the Program."  I am using a Duemilanove I got from a friend, on Windows 7.  I kept getting the error, "avrdude: stk500_getsync(): not in sync: resp=0x00."

I checked the Troubleshooting guide, under the section called "Why I can't upload my programs to the Arduino board?" (http://arduino.cc/en/Guide/Troubleshooting#toc1), and found no viable solutions.

Finally, I found a solution.  Using this USBasp programmer I had on hand (http://www.hobbyking.com/hobbyking/store/uh_viewitem.asp?idproduct=21321&aff=281904), with the version 1.2.6.0 driver installed (http://sourceforge.net/projects/libusb-win32/files/ --> "Download libusb-win32-bin-1.2.6.0.zip (913.2 kB)"), I was able to program the Arduino and get the blink program to load and function.  Then, by reloading the bootloader to the Arduino, using this USBasp programmer, I got the Arduino's built-in programmer to function via its USB cable.  Voila!  All done.

To use the USBasp programmer to upload a program to the Arduino, in the Arduino development program, I selected Tools --> Board --> Arduino Duemilanove w/ATmega 328 (for my particular Arduino), and Tools --> Programmer --> USBasp.  Then, to upload a "sketch" (program), go to File --> Upload Using Programmer (note, the 6-pin header on the USBasp must be plugged into the six pins on the Arduino, with the smooth [cable-less] side of the connector toward the *outside* of the Arduino board). 

To use the USBasp programmer to reload the bootloader to my Arduino, I went to Tools --> Burn Bootloader. 

Once this was done, the Upload function via the USB cable, as the Getting Started Guide explains, worked fine.

Warning: do NOT plug in the USBasp programmer to the Arduino simultaneously with the USB cable to the Arduino, unless the J1 jumper is removed on the USBasp, or problems could arise.  The J1 jumper allows the Arduino to get power via the USBasp programmer.  Therefore, to use only the USBasp programmer, have the J1 jumper on the USBasp programmer, and the Arduino USB cable unplugged.
« Last Edit: April 13, 2013, 07:31:59 pm by panther3001 » Logged

Visit my RC aircraft blog at http://electricrcaircraftguy.blogspot.com/

Offline Offline
Jr. Member
**
Karma: 2
Posts: 72
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

PS. I also checked this thread, and didn't find my solution here, but depending on your reason for getting this error, you may find your solution here:  http://arduino.cc/forum/index.php/topic,28223.0.html
Logged

Visit my RC aircraft blog at http://electricrcaircraftguy.blogspot.com/

Offline Offline
Jr. Member
**
Karma: 1
Posts: 85
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

My experience with this problem relates to a 6 wire connection from FTDI FT232RC Adapter and a Pro Mini.

I've even download the latest Arduino software 1.0.4 including drivers but still no fix.     

This problem is well know refer to the following link:
http://www.arduino.cc/en/Guide/Troubleshooting#upload

which in part refers to:....

Auto-Reset
    If you have a board that doesn't support auto-reset, be sure that you are resetting the board a couple of seconds before uploading. (The Arduino Diecimila, Duemilanove, and Nano support auto-reset as do the LilyPad, Pro, and Pro Mini with 6-pin programming headers).

    However, note that some Diecimila were accidently burned with the wrong bootloader and may require you to physically press the reset button before uploading; see this question below.

    However, on some computers, you may need to press the reset button on the board after you hit the upload button in the Arduino environment. Try different intervals of time between the two, up to 10 seconds or more.

---- end of quote ---

I've also see previous posts about using a capacitor on the DTR line with 6 wire setups but if you look at the Pro Mini schematic  ( from SparkFun site) there is already a 0.1uF cap between the processor RESET line and DTR.

I've not experienced this problem with UNO boards with the onboard USD interface so the only way I've been able to download to a Pro MINI is by using PL2303 style module that is a USB/232/TTL converter with only 4 wires as follows :
5V-------VCC
GND-----GND
TXD------RXI
RXD------TX0

What I do is hold down the reset button, watch the compile happen & when program indicates that it is about to Upload release the reset button and it all works OK.

This is not the most impressive fix for me but if I want to use the Pro MINI boards which are a third of the cost of a UNO then that is the way to go... at this time anyway.

Comments welcome
Logged

Pages: [1]   Go Up
Jump to: