Go Down

Topic: Arduino does not work with my Macbook (Read 857 times) previous topic - next topic


Hey guys,

i bought an Arduino Uno, and it does not work with my Macbook (Mac OS X 10.6.8).

When i try to upload, i get this:

Code: [Select]
Binary sketch size: 5.082 bytes (of a 32.256 byte maximum)
/Users/sousa/Downloads/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin/avrdude -C/Users/sousa/Downloads/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -carduino -P/dev/tty.usbmodemfd121 -b115200 -D -Uflash:w:/var/folders/06/067X3ju3EK8DRKr2IYQwa++++TI/-Tmp-/build457476001272576223.tmp/HelloWorld_i2c.cpp.hex:i

avrdude: Version 5.11, compiled on Sep  2 2011 at 18:52:52
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/Users/sousa/Downloads/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/sousa/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/tty.usbmodemfd121
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

avrdude done.  Thank you.

After this i've been reading all about it on Google, most of the info i got was relative to:

Bad wiring;
Fried Arduino;
USB cable problem;
Bad bootloader;

Well, before trying any solution and ruin the whole thing, i tried the setting on my friend's Macbook, i can't tell you the version, but i know for sure that he had the xCode from Apple installed, don't know if he has something more on AVRdude that i don't

At this point i can see the TX and RX blinking, so i assume it should be uploading, but nothing happens after.

Any advices/tips?

Thank you very much.



i will leave this info here (USB port information)

  ID do produto:   0x0043
  ID do fabricante:   0x2341
  Versão:    0.01
  Número de série:   7523733363635101C120
  Velocidade:   Até 12 Mb/seg
  Fabricante:   Arduino (www.arduino.cc)
  ID da localização:   0xfd120000 / 4
  Corrente disponível (mA):   500
  Corrente necessária (mA):   100

It seems to recognize the Arduino.

What the heck is wrong with this? :(


on your friend's Macbook you should try to upload the Blink example, so you can get feedback by looking at the blinking LED (and if you want to be really sure that the Arduino is executing your sketch you can change the duration of the two delay()s).

I notice that you are trying to upload a HelloWorld_i2c sketch; from the name I would say it's a demo of the i2c protocol, which requires a second device and some wiring. Even if the upload were successful you would probably get no visual feedback. Hence my advice of uploading Blink.

On your Macbook, the problem is that the communication between avrdude and the Arduino times out, and this usually depends on the Usb port or cable. Try changing the Usb port (also updating the selection in the Arduino IDE) and / or the Usb cable. Also disconnect any other Usb device attached to the Macbook, and disable Bluetooth. A powered Usb hub may also help, in case the Macbook is unable to power the Arduino as it should (5V and up to Corrente Disponivel). I assume that the Arduino has no wires, shields or other devices attached, except for the Usb cable.

All these actions are reversible and harmless, and may help identify the source of the problem.


I had the same problem on my Mac. Some friends were kind enough to let me try on their Macs, and interestingly, it worked perfectly on Lion, but not Snow Leopard or Mountain Lion...


I can testify it can work on Snow Leopard as well: mine is SL 10.6.8  ;).

Go Up