Go Down

Topic: Arduino Nano R3.0 upload error (Read 12444 times) previous topic - next topic

hiduino

There may be some voltage tolerance issues with your PCs USB ports.  You may want try it with a USB hub and see if that helps any.


crxguy52

I tried it using an external power supply, I assume it would be the same as a usb hub? It was a converted PC power supply, so it should be pretty clean power.

hiduino

No, not exactly.  With a USB hub the data lines are also regenerated.


danielchow

#18
Dec 24, 2015, 02:49 am Last Edit: Dec 24, 2015, 04:18 am by danielchow
Hello everyone, I realize this is an old post but I'd like to share my experience on this issue and its resolution.

So obviously I have the same problem. I purchased an Arduino Nano ATMega328 V3 from this seller on ebay.

Here is my setup:


Using Arduino IDE V.1.6.5, it didn't work. I plugged in the Nano, it found itself a driver, opened the IDE, set Tools > Board to "Arduino Nano" > Set Tools > Processor to "ATMega328" > Set Port of course. Didn't work.

So I tried it on another computer, Windows 7 with Arduino IDE V.1.6.5 as well and it worked. The only thing I can think of is that I have heavily modified my Arduino libraries with all kinds of updates. Perhaps that had something to do wth it.

So I uninstalled Arduin IDE from my original computer, the one that didn't work. Installed https://www.arduino.cc/en/Main/Donate and it worked. Out of pure curiosity, I also installed the original IDE V.1.6.5 and it also worked.

My conclusion is that one of the libraries I replaced was causing this problem.

danielchow

I should also mention that the seller states that the CH340G model on this Nano replaces the FT232RL - not 100% sure what that means. I believe those parts are the modules that interface the board with the computer via USB. The ebay seller links this shady Russian site to install a driver. I didn't install the driver and still managed to get it working.

mfahim

In some PCs(MAC, .... etc), there is an error in uploading code. so, In Arduino IDE, select Sketch tab -> include Library -> Manage Libraries -> in search type " ftdi" , then in search found install "USB Host shield library".

ballscrewbob

#21
Jul 07, 2016, 04:54 pm Last Edit: Jul 07, 2016, 04:59 pm by Ballscrewbob Reason: typo
@ danielchow

The CH340 uses a seperate driver that should be installed on the computers you intend to use the board with.

They are available here

Another link showing the CH340 itself. note the pictures of the actual CH340 chip as its pretty easy to identify even if it does not have any markings.

Even if your computer works with the CH340 you should still install the driver and especially on other computers you may want to use the board with. Your board does not need to be plugged in during install either. Always install as "Administrator" this is not the same as a user with Admin rights.

Also if you are using USB hubs ensure they have thier own power supply and try to avoid using USB 3 where possible as that can also cause issues.

Cables are also a regular problem with many users so always try other cables too.
It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

davodeky

You may be successful if you use select arduino mini instead of arduino nano. I had the same problem, but it worked when I selected arduino mini instead of arduino nano on the tools settings.

sterretje

Also if you are using USB hubs ensure they have thier own power supply and try to avoid using USB 3 where possible as that can also cause issues.
Is there a technical explanation for avoiding USB 3?
If you understand an example, use it.
If you don't understand an example, don't use it.

Electronics engineer by trade, software engineer by profession. Trying to get back into electronics after 15 years absence.

ballscrewbob

@sterretje

From what I understand its more to do with chipset implementation by motherboard manufacturers than anything else. Each uses a slightly different approach to try reach a USB 3.0 end result but the differences in components used can cause minor issues.

These can be compounded as I suspect also that as its for all intents and purposes it is a COM port then somewhere between the COM and the USB translation something often messes up.

Tests also indicate possible buffer / speed issues, again partly from the above.

A USB 2.0 hub inserted between the USB 3.0 and the Arduino acts as a throttle forcing the USB 3.0 to slow down its transfer speeds. This seems to alleviate the speed / buffer issues.

It is not all chip-sets and some will run perfectly, but for the most part its often better to avoid USB 3.0 or at least rule it out.  I have no idea if anything is being worked on in this aspect as I know there are other serial bugs that are more specific to Arduino than a motherboard chipset.

Sorry if that makes the water a little muddy buts its the best I have from tests and such.




It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

Go Up