Go Down

Topic: Arduino Uno R3 doesn't show up in Mac OS X (10.6.8) system with USB? (Read 4 times) previous topic - next topic

pdirks

Hi Nick,

>A simple test would be to find another PC/Mac somewhere and try that.

That's a great idea!  I tried it on another 10.6.8 system and it also didn't show up but, just in case, I tried it on a system that happened to be running 10.7.  No idea why but the USB modem appeared as expected!  What's more, since that test it's shown up without a problem on my original system, too!  Maybe Mac OS X "Lion" has heretofore unknown curative powers :-)

Thanks to all who replied - aside from the occasional "Serial port in use" that I can manage, I think I'm totally back in business!

Best regards,
-Patrick.

James C4S

"Serial Port in Use"

Can generally be fixed with:
$ sudo mkdir /var/lock
$ sudo chmod 777 /var/lock

Unless, of course, there is actually something keeping the serial port open.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

sector7gp

I got the same issue, I try tons of thinghs, but the solucion was at bit of distance.
I just programm again the xxu2 (in my case the USB2SERIAL with 8u2 chip)

I leave here the link to use the dfu programmer (in mac)
http://fleshandmachines.wordpress.com/2012/11/27/firmware-update-on-arduino-uno/
https://github.com/arduino/Arduino/tree/master/hardware/arduino/firmwares/atmegaxxu2/arduino-usbserial

Go Up