Go Down

Topic: USB Device Not Recognised on Windows 7 (Read 488 times) previous topic - next topic

Chidi47

Just bought a new Arduino UNO R3 board and have been having problems for it to work. Each time I attach it to the USB port of my computer which is running Windows 7, I get the message "USB Device Not Recognised". I've tried to install the driver from the installation guide on the Arduino website but still gets the same thing. Can any one help me on how to get it working on my system or is there any thing I need to set on the board for it to work?
I uploaded some images of what I'm noticing when I attach the board to the USB port.

davidowitz

There are several topics here regarding this subject. If you use the 'search' function, you will find an answer.

Good luck!

David

Louis Davis

What is the Hardware ID for the unknown device?

Go to Device Manager
Right Click unknown device
Select Properties
Select Details tab
Change Property to Hardware Ids
What is displayed under Value?

If it shows USB/Unknown or a ID of all zeroes, then I would try a different cable.
Do you have USB 3.0 ports? There have been some reports of problem with USB 3.0 ports.

Otherwise, if you get a good Hardware ID, then follow this procedure:

Right click the Unknown Device in Device Manager
Select Update Driver Software
Select Browse my computer for software
Click Browse button
Select the Drivers folder under the location of your Arduino software installation. (Do not select the FTDI folder inside the Drivers folder)
Click OK
Click Next

Go Up